# Error on update Logstash 5.2 =\> 5.3

**URL:** https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740
**Category:** Logstash
**Created:** [March 30, 2017, 8:22pm UTC](https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740 "2017-03-30T20:22:24Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![zokratez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zokratez/32/5974_2.png) [@zokratez](https://discuss.elastic.co/u/zokratez)
#### Post date: [March 30, 2017, 8:22pm UTC](https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740/1 "2017-03-30T20:22:25Z")

</div>

After the update I get the following error:

> [2017-03-30T17:17:21,667][ERROR][logstash.filters.kv] Unknown setting 'trim' for kv  
> [2017-03-30T17:17:21,692][ERROR][logstash.agent] Cannot load an invalid configuration {:reason=\>"Something is wrong with your configuration."}

---

<div class="post-metadata">

### Author: ![zokratez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zokratez/32/5974_2.png) [@zokratez](https://discuss.elastic.co/u/zokratez)
#### Post date: [March 30, 2017, 8:28pm UTC](https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740/2 "2017-03-30T20:28:51Z")

</div>

I had a deprecated grok filter for postfix... I just rmove it and now logstash work like a charm.

---

<div class="post-metadata">

### Author: ![jsvd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsvd/32/6203_2.png) [@jsvd](https://discuss.elastic.co/u/jsvd)
#### Post date: [March 31, 2017, 5:00pm UTC](https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740/3 "2017-03-31T17:00:42Z")

</div>

yeah.. version 4.0.0 of the kv filter broke some settings [https://github.com/logstash-plugins/logstash-filter-kv/blob/master/CHANGELOG.md#400](https://github.com/logstash-plugins/logstash-filter-kv/blob/master/CHANGELOG.md#400)

this version wasn't supposted to be included in a logstash minor version but it was..

[This issue](https://github.com/logstash-plugins/logstash-filter-kv/issues/46) was created to track this problem

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 28, 2017, 5:01pm UTC](https://discuss.elastic.co/t/error-on-update-logstash-5-2-5-3/80740/4 "2017-04-28T17:01:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
