# ERROR: org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes were available

**URL:** https://discuss.elastic.co/t/error-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-were-available/22679
**Category:** Elasticsearch
**Created:** [March 16, 2015, 6:58am UTC](https://discuss.elastic.co/t/error-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-were-available/22679 "2015-03-16T06:58:13Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![logan10](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/logan10/32/784_2.png) [@logan10](https://discuss.elastic.co/u/logan10)
#### Post date: [March 16, 2015, 6:58am UTC](https://discuss.elastic.co/t/error-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-were-available/22679/1 "2015-03-16T06:58:13Z")

</div>

Hi All,

I am facing a very strange issue with JAVA API for indexing bulk documents  
on elasticsearch cluster which says:

_org.elasticsearch.client.transport.NoNodeAvailableException: None of the  
configured nodes were available:  
[[Zip-Zap][DurP4l7kSzSerR3rM08PFQ][ip-xx-xx-xx-xx][inet[/xx.xx.xx.xx:9300]]{aws\_availability\_zone=us-east-1d}]_

- at  
org.elasticsearch.client.transport.TransportClientNodesService$RetryListener.onFailure(TransportClientNodesService.java:234)\*

- at  
org.elasticsearch.action.TransportActionNodeProxy$1.handleException(TransportActionNodeProxy.java:78)\*

- at  
org.elasticsearch.transport.TransportService$Adapter$3.run(TransportService.java:323)\*

- at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)\*

- at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)\*

- at java.lang.Thread.run(Thread.java:745)\*

_Caused by: org.elasticsearch.transport.NodeDisconnectedException:  
[Zip-Zap][inet[/xx.xx.xx.xx:9300]][indices:data/write/bulk] disconnected_

Scenario is: I am using elasticsearch 1.4.2 on 3 EC2 nodes (within same  
cluster) all the nodes are up and running but, when I am trying to index  
the documents it gives above exception and the weird part is I am having 2  
different types in it and I am using parent child mapping i.e.  
index: INDEX with 2 types: parentType and childType  
When I am indexing child type it works fine for me but when I an trying to  
index parent it gives NoNode available error while all the nodes are up and  
running.  
Please help I am clueless about this issue.  
My Client code is as follows:

Settings settings = ImmutableSettings._settingsBuilder_().put("cluster.name",  
"CLUSTER\_NAME").build();

Client _transportClient_ = _new_ TransportClient(settings);

transportClient = ((TransportClient) transportClient).addTransportAddress(  
_new_ InetSocketTransportAddress("xx.xx.xx.xxx", 9300))

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/ecc9c92c-5242-47dd-805e-19a616ed494d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/ecc9c92c-5242-47dd-805e-19a616ed494d%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:26am UTC](https://discuss.elastic.co/t/error-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-were-available/22679/2 "2017-07-06T00:26:37Z")

</div>


