# \[ERROR\]\[org.logstash.beats.BeatsHandler\] Exception: not an SSL/TLS record: X

**URL:** <https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108>\
**Category:** Logstash\
**Created:** [November 5, 2016, 8:50pm UTC](https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108 "2016-11-05T20:50:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [November 5, 2016, 8:50pm UTC](https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108/1 "2016-11-05T20:50:12Z")

</div>

I'm trying to resolve my own topic:

> [@Filebeat - ERR Failed to publish events caused by: EOF](https://discuss.elastic.co/t/filebeat-err-failed-to-publish-events-caused-by-eof/65105):
>
> I'm using Elasticsearch, Logstash, Kibana (ELK) Docker image (elk-docker) @ following environment: # cat /etc/redhat-release CentOS Linux release 7.2.1511 (Core) # uname -a Linux X 3.10.0-327.36.3.el7.x86\_64 #1 SMP Mon Oct 24 16:09:20 UTC 2016 x86\_64 x86\_64 x86\_64 GNU/Linux # rpm -q filebeat filebeat-5.0.0-1.x86\_64 # and getting following error while trying to run filebeat (output to logstash): 2016/11/05 19:17:34.996020 sync.go:85: ERR Failed to publish events caused by: EOF 2016/11/05 …

I'm getting following inside of my logstash's log:

> [2016-11-05T20:44:42,999][ERROR][org.logstash.beats.BeatsHandler] Exception: not an SSL/TLS record: X

something to do with SSL/TLS? but where? I left all defaults..

---

<div class="post-metadata">

**Author:** ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Post date:** [November 10, 2016, 12:25pm UTC](https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108/2 "2016-11-10T12:25:38Z")

</div>

Same here. Anyone?  
[ERROR][org.logstash.beats.BeatsHandler] Exception: not an SSL/TLS record

---

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [November 10, 2016, 8:10pm UTC](https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108/3 "2016-11-10T20:10:12Z")

</div>

after making following change on filebeat:

```
$ grep ssl.certificate_authorities /etc/filebeat/filebeat.yml 
  ssl.certificate_authorities: ["/etc/pki/tls/certs/logstash-beats.crt"]
$ 

```

that error went away for me

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2016, 8:10pm UTC](https://discuss.elastic.co/t/error-org-logstash-beats-beatshandler-exception-not-an-ssl-tls-record-x/65108/4 "2016-12-08T20:10:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
