# Error parsing logs in Logstash

**URL:** <https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262>\
**Category:** Logstash\
**Created:** [March 2, 2018, 1:47pm UTC](https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262 "2018-03-02T13:47:21Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![edmx](https://avatars.discourse-cdn.com/v4/letter/e/779978/32.png) [@edmx](https://discuss.elastic.co/u/edmx)\
**Post date:** [March 2, 2018, 1:47pm UTC](https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262/1 "2018-03-02T13:47:21Z")

</div>

Hey guys,

I'm doing the 'Getting started with Logstash' tutorial at this moment.  
[link to tutorial](https://www.elastic.co/guide/en/logstash/current/advanced-pipeline.html)

While I'm following all steps, I'm stuck at an error:

It's this error:

sudo bin/logstash -f first-pipeline.conf --config.reload.automatic  
Sending Logstash's logs to /home/edward/Desktop/prototype/logstash-6.2.2/logs which is now configured via log4j2.properties  
[2018-03-02T14:29:44,862][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/home/edward/Desktop/prototype/logstash-6.2.2/modules/netflow/configuration"}  
[2018-03-02T14:29:44,945][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/home/edward/Desktop/prototype/logstash-6.2.2/modules/fb\_apache/configuration"}  
[2018-03-02T14:29:46,424][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
**[2018-03-02T14:29:46,534][FATAL][logstash.runner] Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.**  
**[2018-03-02T14:29:46,647][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit**

Anyone knows how to fix this problem?  
I have searched all over the internet, but I couldn't find the solution.

Thnx,

---

<div class="post-metadata">

**Author:** ![eperry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eperry/32/551_2.png) [@eperry](https://discuss.elastic.co/u/eperry)\
**Post date:** [March 3, 2018, 12:06pm UTC](https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262/2 "2018-03-03T12:06:54Z")

</div>

Let's assume the the error is correct.

try doing a 'ps -ef | grep logstash' and see if there is one already running if so kill it

---

<div class="post-metadata">

**Author:** ![edmx](https://avatars.discourse-cdn.com/v4/letter/e/779978/32.png) [@edmx](https://discuss.elastic.co/u/edmx)\
**Post date:** [March 6, 2018, 7:47am UTC](https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262/3 "2018-03-06T07:47:35Z")

</div>

Thnx for the info. I have already fixed it.  
The problem was that once it was already run and stopped, it didn't stop the Logstash.runner. I had to reboot the pc and run it once.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 3, 2018, 7:47am UTC](https://discuss.elastic.co/t/error-parsing-logs-in-logstash/122262/4 "2018-04-03T07:47:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
