# Error: Port 5601 is already in use. Another instance of Kibana may be running!

**URL:** <https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070>\
**Category:** Kibana\
**Created:** [July 7, 2020, 1:04am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070 "2020-07-07T01:04:55Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Splunk](https://avatars.discourse-cdn.com/v4/letter/s/8c91f0/32.png) [@Splunk](https://discuss.elastic.co/u/Splunk)\
**Post date:** [July 7, 2020, 1:04am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/1 "2020-07-07T01:04:55Z")

</div>

bin kibana  
` log [22:25:12.491] [warning][plugins-discovery] Expect plugin "id" in camelCase, but found: apm_oss`  
`log [22:25:12.504] [warning][plugins-discovery] Expect plugin "id" in camelCase, but found: triggers_actions_ui`  
` log [22:25:40.082] [info][plugins-service] Plugin "visTypeXy" is disabled.`  
`log [22:25:40.083] [info][plugins-service] Plugin "endpoint" is disabled.`  
` log [22:25:40.083] [info][plugins-service] Plugin "lists" is disabled.`  
`log [22:25:40.083] [info][plugins-service] Plugin "ingestManager" is disabled.`  
` log [22:25:43.113] [warning][config][deprecation] Environment variable "DATA_PATH" will be removed. It has been replaced with kibana.yml setting "path.data"`  
`log [22:25:43.131] [fatal][root] Error: Port 5601 is already in use. Another instance of Kibana may be running!`  
` at Root.shutdown (/usr/local/Cellar/kibana-`full/7.8.0/libexec/src/core/server/root/index.js:67:18)  
`at Root.setup (/usr/local/Cellar/kibana-full/7.8.0/libexec/src/core/server/root/index.js:46:18) `at process.\_tickCallback (internal/process/next\_tick.js:68:7)  
`  
FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

Anyone help me with this.?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 7, 2020, 1:13am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/2 "2020-07-07T01:13:43Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

Are you sure there isn't another Kibana process running?

---

<div class="post-metadata">

**Author:** ![Splunk](https://avatars.discourse-cdn.com/v4/letter/s/8c91f0/32.png) [@Splunk](https://discuss.elastic.co/u/Splunk)\
**Post date:** [July 7, 2020, 1:26am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/3 "2020-07-07T01:26:45Z")

</div>

> [@warkolm](#):
>
> re you sure there isn't another Kibana proces

thanks for your reply, yes i changed the format sorry.

ps aux | grep kibana  
root 12378 0.0 0.0 4278540 736 s001 S+ 5:38PM 0:00.00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn --exclude-dir=.idea --exclude-dir=.to

i tried installing kibana last week but not successful, if that could be a problem how can i remove old files?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 7, 2020, 1:27am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/4 "2020-07-07T01:27:54Z")

</div>

What does `sudo lsof -i:5601` show?  
If that doesn't work, try one of the other options [here](https://www.cyberciti.biz/faq/unix-linux-check-if-port-is-in-use-command/).

---

<div class="post-metadata">

**Author:** ![Splunk](https://avatars.discourse-cdn.com/v4/letter/s/8c91f0/32.png) [@Splunk](https://discuss.elastic.co/u/Splunk)\
**Post date:** [July 7, 2020, 1:31am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/5 "2020-07-07T01:31:53Z")

</div>

`bin sudo lsof -i:5601`  
Password:  
`COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME node 8333 root 25u IPv4 0x4e19f76e1ab38273 0t0 TCP localhost:esmagent (LISTEN)`

`i should kill this process`?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 7, 2020, 1:44am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/6 "2020-07-07T01:44:06Z")

</div>

It's really hard to see what is happening here as your formatting is not the best.

But it looks like there's a process called `esmagent` that is running. I don't know what that is, so I wouldn't suggest arbitrarily killing it unless you know what it does.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 4, 2020, 1:44am UTC](https://discuss.elastic.co/t/error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/240070/7 "2020-08-04T01:44:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
