# Error \[ProductNotSupportedSecurityError\]: The client is unable to verify that the server is Elasticsearch due to security privileges on the server side. Some functionality may not be compatible if the server is running an unsupported product

**URL:** <https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [June 18, 2022, 3:59am UTC](https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554 "2022-06-18T03:59:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [June 18, 2022, 3:59am UTC](https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554/1 "2022-06-18T03:59:37Z")

</div>

Hello World!

I'm trying to follow [Install Kibana with Docker | Kibana Guide [7.17] | Elastic](https://www.elastic.co/guide/en/kibana/7.17/docker.html#run-kibana-on-docker-for-dev) and running into following error:

> Error [ProductNotSupportedSecurityError]: The client is unable to verify that the server is Elasticsearch due to security privileges on the server side. Some functionality may not be compatible if the server is running an unsupported product.

```auto
kib01 | {"type":"log","@timestamp":"2022-06-18T03:50:13+00:00","tags":["warning","process"],"pid":7,"message":"Error [ProductNotSupportedSecurityError]: The client is unable to verify that the server is Elasticsearch due to security privileges on the server side. Some functionality may not be compatible if the server is running an unsupported product.\n at /usr/share/kibana/node_modules/@elastic/elasticsearch/lib/Transport.js:576:19\n at onBody (/usr/share/kibana/node_modules/@elastic/elasticsearch/lib/Transport.js:369:9)\n at IncomingMessage.onEnd (/usr/share/kibana/node_modules/@elastic/elasticsearch/lib/Transport.js:291:11)\n at IncomingMessage.emit (node:events:538:35)\n at endReadableNT (node:internal/streams/readable:1345:12)\n at processTicksAndRejections (node:internal/process/task_queues:83:21)"}
kib01 | {"type":"log","@timestamp":"2022-06-18T03:50:13+00:00","tags":["error","elasticsearch-service"],"pid":7,"message":"Unable to retrieve version information from Elasticsearch nodes. security_exception: [security_exception] Reason: unable to authenticate user [kibana_system] for REST request [/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip]"}

```

I'm running 7.17.3 version both elasticsearch cluster and kibana container.

Please advise)  
Thanks!

---

<div class="post-metadata">

**Author:** ![jsanz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsanz/32/53734_2.png) [@jsanz](https://discuss.elastic.co/u/jsanz)\
**Post date:** [June 29, 2022, 12:53pm UTC](https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554/2 "2022-06-29T12:53:06Z")

</div>

You have this:

> Reason: unable to authenticate user [kibana\_system]

Are you sure `kibana_system` user is ready? have you tried to log into elasticsearch with it from an external source like `curl` or any other http client?

---

<div class="post-metadata">

**Author:** ![alexus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alexus/32/12696_2.png) [@alexus](https://discuss.elastic.co/u/alexus)\
**Post date:** [June 29, 2022, 9:24pm UTC](https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554/3 "2022-06-29T21:24:53Z")

</div>

reading:

> **[Built-in users | Elasticsearch Guide \[7.17\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.17/built-in-users.html)**

thanks @jsanz

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 27, 2022, 9:25pm UTC](https://discuss.elastic.co/t/error-productnotsupportedsecurityerror-the-client-is-unable-to-verify-that-the-server-is-elasticsearch-due-to-security-privileges-on-the-server-side-some-functionality-may-not-be-compatible-if-the-server-is-running-an-unsupported-product/307554/4 "2022-07-27T21:25:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
