# Error publishing events from filebeat

**URL:** <https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 1, 2016, 12:52pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759 "2016-12-01T12:52:50Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![aparadka](https://avatars.discourse-cdn.com/v4/letter/a/839c29/32.png) [@aparadka](https://discuss.elastic.co/u/aparadka)\
**Post date:** [December 1, 2016, 12:52pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/1 "2016-12-01T12:52:50Z")

</div>

![](https://us1.discourse-cdn.com/elastic/original/2X/6/67cef17aec5dc0aa838f8aecea7b0fce47b74fe4.png)

This is the error i'm encountering while sending the file from FB--\>LS--\>ES.

This is what the LS console is showing

 ![](https://us1.discourse-cdn.com/elastic/original/2X/6/6c60d9307b5a3def923de9a5e8e2202f1ae0b8a8.JPG)

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [December 1, 2016, 1:09pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/2 "2016-12-01T13:09:04Z")

</div>

Is this a new question or the same as posted here? [Filebeat unable to send data to elastic search](https://discuss.elastic.co/t/filebeat-unable-to-send-data-to-elastic-search/67708) As mentioned there, please post logs as text or link a gist.

Also please always add details on what versions you are using and what your setup is.

---

<div class="post-metadata">

**Author:** ![aparadka](https://avatars.discourse-cdn.com/v4/letter/a/839c29/32.png) [@aparadka](https://discuss.elastic.co/u/aparadka)\
**Post date:** [December 2, 2016, 4:56am UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/3 "2016-12-02T04:56:01Z")

</div>

version used is **5.0.1** and the error is **Connecting error publishing events (retrying) :dial tcp 127.0.0.1:5044 connnectex: no connection could be made because the target machine actively refused it.**  
This is what it shows on the filebeat side.

And on the logstash side the error is **Got a bad response code from server, but this code is not considered retryable. The request will be dropped (:code=\>403)**

---

<div class="post-metadata">

**Author:** ![tudor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tudor/32/3753_2.png) [@tudor](https://discuss.elastic.co/u/tudor)\
**Post date:** [December 2, 2016, 1:08pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/4 "2016-12-02T13:08:44Z")

</div>

The Logstash logs seem to indicate that you are using the TCP input? You should use the Beats input with Filebeat. If you are using the beats input, please post your LS config.

---

<div class="post-metadata">

**Author:** ![aparadka](https://avatars.discourse-cdn.com/v4/letter/a/839c29/32.png) [@aparadka](https://discuss.elastic.co/u/aparadka)\
**Post date:** [December 7, 2016, 4:27am UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/5 "2016-12-07T04:27:41Z")

</div>

I'm using beats input in the ls config with filebeat.  
Here is my conf file for LS

input {  
beats {  
host =\> "localhost"  
port =\> 5044  
codec =\> plain { charset =\> "ISO-8859-1" }

}  
}

output {  
elasticsearch {  
hosts =\> "[http://127.0.0.1:9200](http://127.0.0.1:9200)"  
manage\_template =\> false  
index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
user =\> logstash\_internal  
password =\> changeme  
}  
}

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [December 7, 2016, 12:36pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/6 "2016-12-07T12:36:49Z")

</div>

looks like you're having two problems. The `403` from LS to ES.

For beats to LS the connection is not accepted by LS. Maybe LS is blocked due to pipeline/output not working correctly.

---

<div class="post-metadata">

**Author:** ![aparadka](https://avatars.discourse-cdn.com/v4/letter/a/839c29/32.png) [@aparadka](https://discuss.elastic.co/u/aparadka)\
**Post date:** [December 8, 2016, 5:51am UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/7 "2016-12-08T05:51:31Z")

</div>

I solved this issue.. Thank you all!!

---

<div class="post-metadata">

**Author:** ![Josh\_A](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/josh_a/32/42035_2.png) [@Josh\_A](https://discuss.elastic.co/u/Josh_A)\
**Post date:** [December 21, 2016, 5:50pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/8 "2016-12-21T17:50:30Z")

</div>

Akash - how did you solve it?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 18, 2017, 5:50pm UTC](https://discuss.elastic.co/t/error-publishing-events-from-filebeat/67759/9 "2017-01-18T17:50:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
