# Error Reloading pipelines.yml While Logstash Is Running

**URL:** <https://discuss.elastic.co/t/error-reloading-pipelines-yml-while-logstash-is-running/166672>\
**Category:** Logstash\
**Created:** [February 1, 2019, 5:03am UTC](https://discuss.elastic.co/t/error-reloading-pipelines-yml-while-logstash-is-running/166672 "2019-02-01T05:03:38Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![henrytran026](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/henrytran026/32/40457_2.png) [@henrytran026](https://discuss.elastic.co/u/henrytran026)\
**Post date:** [February 1, 2019, 5:03am UTC](https://discuss.elastic.co/t/error-reloading-pipelines-yml-while-logstash-is-running/166672/1 "2019-02-01T05:03:38Z")

</div>

- Version: 6.5.4
- Operating System: Running with Docker
- Config File:

pipelines.yml

```auto
- pipeline.id: test-app
   path.config: "pipeline/test-app-pipeline.conf"
- pipeline.id: test-app1
   path.config: "pipeline/test-app1-pipeline.conf"

```

- Error Message:  
`[2019-02-01T03:36:48,658][ERROR][logstash.config.sourceloader] Could not fetch all the sources {:exception=>LogStash::ConfigurationError, :message=>"Failed to read pipelines yaml file. Location: /usr/share/logstash/config/pipelines.yml, Exception: java.lang.RuntimeException: Unhandled IOException: java.io.IOException: unhandled errno: Input/output error", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/config/source/multi_local.rb:80:in`read\_pipelines\_from\_yaml'", "/usr/share/logstash/logstash-core/lib/logstash/config/source/multi\_local.rb:65:in `retrieve_yaml_pipelines'", "/usr/share/logstash/logstash-core/lib/logstash/config/source/multi_local.rb:16:in`pipeline\_configs'", "/usr/share/logstash/logstash-core/lib/logstash/config/source\_loader.rb:61:in `block in fetch'", "org/jruby/RubyArray.java:2481:in`collect'", "/usr/share/logstash/logstash-core/lib/logstash/config/source\_loader.rb:60:in `fetch'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:150:in`converge\_state\_and\_update'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:118:in `block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/interval.rb:18:in`interval'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:107:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:362:in`block in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:24:in `block in initialize'"]}`
- Steps to Reproduce:  
I run Logstash docker image with config.reload.automatic set to true to leverage pipelines.yml file. **Everything works fine up to this point. The log files get parsed and indexed to Elasticsearch database, blah blah.** While Logstash is still up, I try to remove a pipeline from the pipelines.yml file. Logstash notices the changes but unable to reload. It produces the message above. The same thing happens when I try to add a pipeline to the pipelines.yml file (of course, I have added the pipeline conf file before doing this).

Also note that when I make changes to each individual pipeline's config files (test-app-pipeline.conf & test-app1-pipeline.conf), Logstash notices the changes and automatically reloads, and everything works perfectly fine. Only when I make changes to the pipelines.yml, I got this error.

I currently use docker compose to manage the containers (ES, Logstash, and Kibana). One of my goals is to **be able to dynamically add and remove pipelines while the whole stack is running**.  
Could anyone please give me some insight to this issue? I appreciate a lot.

---

<div class="post-metadata">

**Author:** ![henrytran026](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/henrytran026/32/40457_2.png) [@henrytran026](https://discuss.elastic.co/u/henrytran026)\
**Post date:** [February 1, 2019, 6:50am UTC](https://discuss.elastic.co/t/error-reloading-pipelines-yml-while-logstash-is-running/166672/2 "2019-02-01T06:50:01Z")

</div>

I have found the solution.

Apparently when I edit pipelines.yml with pycharm, the bind-mounted file is corrupted and unable to read by the container. I realize this when I go into the container and try to cat the file. It gives me Input/Output Error. By following this thread I am now able to get it working.

> <https://stackoverflow.com/questions/47031807/input-output-error>

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 1, 2019, 6:50am UTC](https://discuss.elastic.co/t/error-reloading-pipelines-yml-while-logstash-is-running/166672/3 "2019-03-01T06:50:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
