# Error restarting service after change data path

**URL:** <https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378>\
**Category:** Elasticsearch\
**Created:** [September 16, 2015, 9:52am UTC](https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378 "2015-09-16T09:52:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![carlosvega](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carlosvega/32/28433_2.png) [@carlosvega](https://discuss.elastic.co/u/carlosvega)\
**Post date:** [September 16, 2015, 9:52am UTC](https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378/1 "2015-09-16T09:52:22Z")

</div>

I made a clean install of elasticsearch and changed the data.path in the yml file like this:

> path.data: /media/ssd/elasticsearch\_data/

but I'm getting an error every time I restart the service:

> Sep 16 11:46:03 hel systemd[1]: Starting Elasticsearch...  
> Sep 16 11:46:03 hel systemd[1]: Started Elasticsearch.  
> Sep 16 11:46:05 hel elasticsearch[30622]: {1.7.2}: Initialization Failed ...  
> Sep 16 11:46:05 hel elasticsearch[30622]: - ElasticsearchIllegalStateException[Failed to created node environment]  
> Sep 16 11:46:05 hel elasticsearch[30622]: AccessDeniedException[/media/ssd/elasticsearch\_data/hpcn\_es\_cluster/nodes]  
> Sep 16 11:46:05 hel systemd[1]: elasticsearch.service: main process exited, code=exited, status=3/NOTIMPLEMENTED  
> Sep 16 11:46:05 hel systemd[1]: Unit elasticsearch.service entered failed state.

The log says:

> [2015-09-16 11:46:05,355][INFO][node] [es\_hele] version[1.7.2], pid[30622], build[e43676b/2015-09-14T09:49:53Z]  
> [2015-09-16 11:46:05,355][INFO][node] [es\_hele] initializing ...  
> [2015-09-16 11:46:05,417][INFO][plugins] [es\_hele] loaded , sites   
> [2015-09-16 11:46:05,438][ERROR][bootstrap] Exception  
> org.elasticsearch.ElasticsearchIllegalStateException: Failed to created node environment  
> at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:167)  
> at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:159)  
> at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:77)  
> at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:245)  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)  
> Caused by: java.nio.file.AccessDeniedException: /media/ssd/elasticsearch\_data/hpcn\_es\_cluster/nodes  
> at sun.nio.fs.UnixException.translateToIOException(Unknown Source)  
> at sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)  
> at sun.nio.fs.UnixException.rethrowAsIOException(Unknown Source)  
> at sun.nio.fs.UnixFileSystemProvider.checkAccess(Unknown Source)  
> at java.nio.file.Files.createDirectories(Unknown Source)  
> at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:132)  
> at org.elasticsearch.node.internal.InternalNode.(InternalNode.java:165)  
> ... 4 more

Is there any permission requirement for this folder?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 16, 2015, 10:22am UTC](https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378/2 "2015-09-16T10:22:23Z")

</div>

> [@carlosvega](#):
>
> AccessDeniedException: /media/ssd/elasticsearch\_data/hpcn\_es\_cluster/nodes

Yeah, the `elasticsearch` user needs read and write.

---

<div class="post-metadata">

**Author:** ![carlosvega](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carlosvega/32/28433_2.png) [@carlosvega](https://discuss.elastic.co/u/carlosvega)\
**Post date:** [September 16, 2015, 10:23am UTC](https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378/3 "2015-09-16T10:23:13Z")

</div>

I fixed it by giving the right permissions to the mount point. My fault. 😑  
But is fixed now ! 😄

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:50pm UTC](https://discuss.elastic.co/t/error-restarting-service-after-change-data-path/29378/4 "2017-07-05T23:50:04Z")

</div>


