# Error running sudo filebeat setup command

**URL:** <https://discuss.elastic.co/t/error-running-sudo-filebeat-setup-command/302273>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 12, 2022, 8:03pm UTC](https://discuss.elastic.co/t/error-running-sudo-filebeat-setup-command/302273 "2022-04-12T20:03:39Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![LeonardoCoco](https://avatars.discourse-cdn.com/v4/letter/l/82dd89/32.png) [@LeonardoCoco](https://discuss.elastic.co/u/LeonardoCoco)\
**Post date:** [April 12, 2022, 8:03pm UTC](https://discuss.elastic.co/t/error-running-sudo-filebeat-setup-command/302273/1 "2022-04-12T20:03:39Z")

</div>

I'm configuring Elasticsearch, Kibana and Filebeat from scratch.

I have already configured the Elasticsearch.yam, kibana.yam files and I am finishing the filebeat installation, but when executing the command below, the following error message appears:

sudo filebeat setup

"Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to [http://localhost:5601/api/status](http://localhost:5601/api/status) fails: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet."

---

<div class="post-metadata">

**Author:** ![LeonardoCoco](https://avatars.discourse-cdn.com/v4/letter/l/82dd89/32.png) [@LeonardoCoco](https://discuss.elastic.co/u/LeonardoCoco)\
**Post date:** [April 13, 2022, 4:51pm UTC](https://discuss.elastic.co/t/error-running-sudo-filebeat-setup-command/302273/2 "2022-04-13T16:51:33Z")

</div>

Solution:

The solution adopted was to use the method is to store the values in Kibana’s _keystore_ , which is an obfuscated file that Kibana can use to store secrets.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2022, 6:51pm UTC](https://discuss.elastic.co/t/error-running-sudo-filebeat-setup-command/302273/3 "2022-05-11T18:51:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
