# Error sending data to APM server

**URL:** <https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695>\
**Category:** APM\
**Tags:** server\
**Created:** [September 21, 2021, 9:01am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695 "2021-09-21T09:01:15Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Prasanth\_V](https://avatars.discourse-cdn.com/v4/letter/p/8c91f0/32.png) [@Prasanth\_V](https://discuss.elastic.co/u/Prasanth_V)\
**Post date:** [September 21, 2021, 9:01am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/1 "2021-09-21T09:01:15Z")

</div>

Dear Team,

I'm facing the below issue, Could you please suggest me?

Note: We've a sufficient disk space and CPU core.

```auto
2021-09-21 12:07:05,978 [elastic-apm-server-reporter] WARN co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - {
  "accepted": 0,
  "errors": [
    {
      "message": "queue is full"
    }
  ]
}

```

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [September 21, 2021, 9:40am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/2 "2021-09-21T09:40:34Z")

</div>

Please see [Common problems | APM Server Reference [7.14] | Elastic](https://www.elastic.co/guide/en/apm/server/current/common-problems.html#queue-full)

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [September 21, 2021, 2:57pm UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/3 "2021-09-21T14:57:52Z")

</div>

How would you do this for Fleet's APM Server as there is a limited amount of configuration options.

It would help if there was a away to disable irrelevant calls looking for a central configuration management, which is not currently possible with Fleet's APM module and Beats Instrumentation which is making these useful request to the APM server.

> forbidden request: Agent remote configuration is disabled. Configure the `apm-server.kibana` section in apm-server.yml to enable it. If you are using a RUM agent, you also need to configure the `apm-server.rum` section. If you are not using remote configuration, you can safely ignore this error.

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [September 22, 2021, 2:20am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/4 "2021-09-22T02:20:22Z")

</div>

> How would you do this for Fleet's APM Server as there is a limited amount of configuration options.

@zx8086 great question! Currently there is only limited support for tuning output settings when running the Fleet/Agent integration. You can configure Elasticsearch output settings globally for all agents via Fleet settings:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/8/481dbe477cc82a47616674cc6296af6c85588959.png)

We are currently investigating making APM Server more self-tuning, which will apply when running with or without Fleet.

> It would help if there was a away to disable irrelevant calls looking for a central configuration management, which is not currently possible with Fleet's APM module and Beats Instrumentation which is making these useful request to the APM server.

Support for APM Agent central config was added to the integration in 7.14.0, so you should not be seeing those errors. Are you running 7.14.x?

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [September 22, 2021, 10:01am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/5 "2021-09-22T10:01:26Z")

</div>

> Support for APM Agent central config was added to the integration in 7.14.0, so you should not be seeing those errors. Are you running 7.14.x?

Running 7.14.2 across the board. It seems the errors are due to the Beats Agents and their APM Instrumentation, as this is the offending query captured below, communicating with the Fleet's Elastic Agents APM Service's response. In this case it for Auditbeat

 ![Screen Shot 2021-09-22 at 11.52.37 AM](https://us1.discourse-cdn.com/elastic/original/3X/a/9/a9dfd5b0a722a394c6da00d4d83f6a82071d44e2.png)

```auto
# Instrumentation support for the packetbeat.
instrumentation:
    # Set to true to enable instrumentation of packetbeat.
    enabled: true

    # Environment in which packetbeat is running on (eg: staging, production, etc.)
    environment: "Development"

    # APM Server hosts to report instrumentation results to.
    hosts:
      - http://192.168.0.3:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.
    #api_key:

    # Secret token for the APM Server(s).
    secret_token: "REDACTED"

```

There is not problem with the data getting into the APM Kibana dashboards, it just seems the Beat Agents are trying to get a configuration of sorts. 192.168.0.7 (GaalDornick)

 ![Screen Shot 2021-09-22 at 12.00.01 PM](https://us1.discourse-cdn.com/elastic/original/3X/c/3/c3bcb8431f4abab059df8de26cc5692fa0116024.png)

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [September 23, 2021, 2:23am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/6 "2021-09-23T02:23:56Z")

</div>

Thanks for the details. I suspect we're just incorrectly logging an error because there's no APM agent central config defined. We'll take a closer look to verify and sort it out.

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [September 23, 2021, 2:26am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/7 "2021-09-23T02:26:59Z")

</div>

Actually, no need to look further into it. I just remembered I already fixed this recently: [https://github.com/elastic/apm-server/pull/5917](https://github.com/elastic/apm-server/pull/5917). This fix is in 7.15.0 which was just released. You should no longer see those errors logged after upgrading.

---

<div class="post-metadata">

**Author:** ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)\
**Post date:** [September 23, 2021, 2:31am UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/8 "2021-09-23T02:31:57Z")

</div>

Thanks, it just was jarring to seen 403 errors, but 7.15 seems to have cleared this up ! Well done for the fix ✌

 ![Screen Shot 2021-09-23 at 4.29.51 AM](https://us1.discourse-cdn.com/elastic/original/3X/6/6/6639d729c81d17a85e856ff20f09d549e8b5eaa8.jpeg)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2021, 10:32pm UTC](https://discuss.elastic.co/t/error-sending-data-to-apm-server/284695/9 "2021-10-13T22:32:30Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
