# Error setting up Filebeat on Windows

**URL:** <https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 18, 2016, 5:30pm UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169 "2016-02-18T17:30:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Vishesh](https://avatars.discourse-cdn.com/v4/letter/v/ed8c4c/32.png) [@Vishesh](https://discuss.elastic.co/u/Vishesh)\
**Post date:** [February 18, 2016, 5:30pm UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169/1 "2016-02-18T17:30:53Z")

</div>

After starting the service, I am constantly facing a connection error:

SSL Client failed to connect with: dial tcp x.x.x.x:5044  
No connection could be made because the target machine actively refused it.

 ![](https://us1.discourse-cdn.com/elastic/original/2X/5/50367212acac94c3b88420a82832494038298d6f.PNG)

Here is my filebeat.yml file:

> ```
> filebeat:
> # List of prospectors to fetch data.
> prospectors:
> paths:
> - C:\xampp\htdocs\order-core\storage\logs\*.log
> 
> ```

> ```
> input_type: log
> 
> ```

> ```
> fields:
> product: prod_namev5
> 
> ```

> ```
> fields_under_root: true
> 
> ```

> ```
> document_type: log
> 
> ```

> ```
> tail_files: true
> 
> ```

> ```
> registry_file: "C:\ProgramData\filebeat\registry"
> 
> ```

> ```
> output:
> 
> ```

> ```
> ### Logstash as output
> logstash:
> # The Logstash hosts
> hosts: ["x.x.x.x:5044"]
> 
> ```

> ```
> # Optional TLS. By default is off.
> tls:
> # List of root certificates for HTTPS server verifications
> certificate_authorities: ["C:/Program Files/Filebeat/certs/logstash-forwarder.crt"]
> 
> ```

> ```
> shipper:
> 
> ```

> ```
> logging:
> files:
> rotateeverybytes: 10485760 # = 10MB
> 
> ```

How do I fix this issue?

PS: I've also attached screenshot for the response I'm getting after starting the service  
Thanks in advance! 🙂

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [February 18, 2016, 6:12pm UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169/2 "2016-02-18T18:12:25Z")

</div>

Can you post your logstash config please? Any logs in logstash regarding connection failure?

---

<div class="post-metadata">

**Author:** ![Vishesh](https://avatars.discourse-cdn.com/v4/letter/v/ed8c4c/32.png) [@Vishesh](https://discuss.elastic.co/u/Vishesh)\
**Post date:** [February 19, 2016, 6:43am UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169/3 "2016-02-19T06:43:03Z")

</div>

Hi Steffans!

There is no log related to the "connection error" inside my log file, that I'm trying to push to the server.

As a side note, the location of my certificate file and the corresponding key file is as follows:  
Certificate Location: "C:/Program Files/Filebeat/certs/logstash-forwarder.crt"  
Certificate Key Location: "C:/Program Files/Filebeat/private/logstash-forwarder.key"  
Could the issue be directory related too?

I did start the service again, and getting the following response now:

 ![](https://us1.discourse-cdn.com/elastic/original/2X/c/c6dacf0f68c465a81ac9ca2c0e4f655ef0622fd4.PNG)

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [February 19, 2016, 5:20pm UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169/4 "2016-02-19T17:20:07Z")

</div>

Can you post your logstash config?

Any firewall in between?

Have you tried to ping the logstash server?

Have you tried to telnet logstash server on port 5044?

Connetion is refused by logstash server for some reason, e.g. wrong port or firewall rules.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:55pm UTC](https://discuss.elastic.co/t/error-setting-up-filebeat-on-windows/42169/5 "2017-07-05T21:55:31Z")

</div>


