# Error showing while displaying an old dashboard

**URL:** <https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505>\
**Category:** Kibana\
**Created:** [February 19, 2018, 6:17pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505 "2018-02-19T18:17:14Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![dorj1234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorj1234/32/21339_2.png) [@dorj1234](https://discuss.elastic.co/u/dorj1234)\
**Post date:** [February 19, 2018, 6:17pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/1 "2018-02-19T18:17:15Z")

</div>

Hello, I am getting the error in the screenshot, can anyone point me in the right direction to resolve this?  
It's a dashboard that worked from 5.6.x to 6.0 and nothing changed, aside from the ELK version (6.2.1)

The error text did not show any hints when I searched.

```auto
Uncaught TypeError: xScale.domain(...)[1].getTime is not a function (http://10.xx.xx.171:5601/bundles/vendors.bundle.js?v=16573:6)

Error: Uncaught TypeError: xScale.domain(...)[1].getTime is not a function (http://10.xx.xx.171:5601/bundles/vendors.bundle.js?v=16573:6)
    at window.onerror (http://10.16.172.171:5601/bundles/commons.bundle.js?v=16573:1:496140)

```

Update: I found the specific visualization that caused the error. It's a date field that I used as a bucket, but instead of data-histogam I used terms, and sorted and chose last X terms.

It always worked, not sure why it doesn't work now.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/9/49d5200c396e8f29548bc6d461cd96ab8d0729be.png)

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [February 19, 2018, 9:03pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/2 "2018-02-19T21:03:17Z")

</div>

Hi,

I am confused. Is it working for you now?

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![dorj1234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorj1234/32/21339_2.png) [@dorj1234](https://discuss.elastic.co/u/dorj1234)\
**Post date:** [February 20, 2018, 12:09am UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/3 "2018-02-20T00:09:37Z")

</div>

Once I changed the bucket to date histogram (it was terms) then the error was gone.  
Problem solved, but I don't understand why would 6.2.1 have a problem with a bucket that is a term --\> date

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [February 20, 2018, 1:32pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/4 "2018-02-20T13:32:11Z")

</div>

@ppisljar, I am not sure whats happening here.

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![ppisljar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppisljar/32/11588_2.png) [@ppisljar](https://discuss.elastic.co/u/ppisljar)\
**Post date:** [February 20, 2018, 1:36pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/5 "2018-02-20T13:36:32Z")

</div>

if you can reproduce this again then please open an issue on [https://github.com/elastic/kibana/issues](https://github.com/elastic/kibana/issues)

thank you

---

<div class="post-metadata">

**Author:** ![dorj1234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorj1234/32/21339_2.png) [@dorj1234](https://discuss.elastic.co/u/dorj1234)\
**Post date:** [February 20, 2018, 3:30pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/6 "2018-02-20T15:30:59Z")

</div>

Yes I can reproduce it. As soon as I return the bucket to terms --\> date I get an error.  
Issue opened [here](https://github.com/elastic/kibana/issues/16825).

Screenshot here. If I hit the "run" triangle I get the error.  
(see error below the screenshot)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/2/32307528f65437226a9730bf13a12b2f73b8b334.png)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/a/ba9f7f3e9aa655ee6a3308a7cb53ab56c00f9085.png)

---

<div class="post-metadata">

**Author:** ![ppisljar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppisljar/32/11588_2.png) [@ppisljar](https://discuss.elastic.co/u/ppisljar)\
**Post date:** [February 20, 2018, 3:53pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/7 "2018-02-20T15:53:19Z")

</div>

thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 20, 2018, 3:54pm UTC](https://discuss.elastic.co/t/error-showing-while-displaying-an-old-dashboard/120505/8 "2018-03-20T15:54:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
