# Error shows in kibana

**URL:** https://discuss.elastic.co/t/error-shows-in-kibana/109739
**Category:** Elasticsearch
**Created:** [November 30, 2017, 11:29am UTC](https://discuss.elastic.co/t/error-shows-in-kibana/109739 "2017-11-30T11:29:41Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![narasiman1986](https://avatars.discourse-cdn.com/v4/letter/n/ce73a5/32.png) [@narasiman1986](https://discuss.elastic.co/u/narasiman1986)
#### Post date: [November 30, 2017, 11:29am UTC](https://discuss.elastic.co/t/error-shows-in-kibana/109739/1 "2017-11-30T11:29:42Z")

</div>

Discover: Request to Elasticsearch failed: {"error":{"root\_cause":[],"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":[]},"status":503}

how to solve this error

i am importing my sql work bench record into elastic search using log stash

in my sql table 22 Lakhs record will be there

First i run the elastic search 5.6.4  
Second i run the kibana 5.6.4  
Third i run the log stash 5.6.4

when i run in log stash 5.6.4, from my SQL table record is displaying.

In kibana, discover tab window when i click refresh button record hits show in the top of kibana window 6.403 hits.

when i click refresh button record the below error shows

Discover: Request to Elasticsearch failed: {"error":{"root\_cause":[],"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":[]},"status":503}

---

<div class="post-metadata">

### Author: ![Julien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien/32/19688_2.png) [@Julien](https://discuss.elastic.co/u/Julien)
#### Post date: [December 8, 2017, 8:47pm UTC](https://discuss.elastic.co/t/error-shows-in-kibana/109739/2 "2017-12-08T20:47:01Z")

</div>

We are lacking some information...  
Can you share the error(s) you see in the logs (elasticsearch logs - logstash or the sql table are unrelated to the error here as kibana sends a request to elasticsearch which reports all shards failed)?  
What happens when you run a search for the index patter you defined in Dev tools ?  
GET pattern\*/\_search

HTTP 503 is the code for service unavailable meaning there is probably at least one error in elasticsearch logs that will give information on what is happening

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 5, 2018, 8:47pm UTC](https://discuss.elastic.co/t/error-shows-in-kibana/109739/3 "2018-01-05T20:47:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
