# ERROR: Skipping security auto configuration because it appears that the node is not starting up for the first time. The node might already be part of a cluster and this auto setup utility is designed to configure Security for new clusters only

**URL:** <https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [March 24, 2022, 12:01pm UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568 "2022-03-24T12:01:25Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![qili](https://avatars.discourse-cdn.com/v4/letter/q/d6d6ee/32.png) [@qili](https://discuss.elastic.co/u/qili)\
**Post date:** [March 24, 2022, 12:01pm UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568/1 "2022-03-24T12:01:25Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/e/a/eac8a04125822effa1fcc36a888a5186ff3c9b72.png)  
why？

I use es8.1.1 mast node had Started ，but failed to join cluster from node

mast node is ：

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/9/09290e179554d30485d7b37ff1ab290250782601.png)

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [March 24, 2022, 1:52pm UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568/2 "2022-03-24T13:52:40Z")

</div>

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with `</>` icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

> [@qili](#):
>
> why？

Because, as the message is saying, you have previously started this node.

`elasticsearch-reconfigure-node` is only meant to be run for nodes that have been installed with either a DEB or an RPM package and should be run _directly_ after installation of the subsequent nodes.

If and only if this is installed with a DEB package, The easiest/simplest way forward for you is to

1. remove/purge the installation ( you need to purge so that the data and config dirs are removed too ) on ubuntu-sv-222 with `apt remove --purge elasticsearch`
2. Install it again
3. Run the `elasticsearch-reconfigure-node` tool _before_ starting elasticsearch
4. Start elasticsearch

---

<div class="post-metadata">

**Author:** ![qili](https://avatars.discourse-cdn.com/v4/letter/q/d6d6ee/32.png) [@qili](https://discuss.elastic.co/u/qili)\
**Post date:** [April 2, 2022, 6:12am UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568/3 "2022-04-02T06:12:19Z")

</div>

The data of the folder that solved my previous installation problem, because it has not been deleted, I hope to help new students who install it，thanks。

---

<div class="post-metadata">

**Author:** ![qili](https://avatars.discourse-cdn.com/v4/letter/q/d6d6ee/32.png) [@qili](https://discuss.elastic.co/u/qili)\
**Post date:** [April 2, 2022, 6:41am UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568/4 "2022-04-02T06:41:38Z")

</div>

thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 30, 2022, 6:42am UTC](https://discuss.elastic.co/t/error-skipping-security-auto-configuration-because-it-appears-that-the-node-is-not-starting-up-for-the-first-time-the-node-might-already-be-part-of-a-cluster-and-this-auto-setup-utility-is-designed-to-configure-security-for-new-clusters-only/300568/5 "2022-04-30T06:42:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
