# Error starting Dev Environment Kibana5-alpha4

**URL:** https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827
**Category:** Kibana
**Created:** [July 6, 2016, 1:37pm UTC](https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827 "2016-07-06T13:37:38Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dlumbrer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dlumbrer/32/8323_2.png) [@dlumbrer](https://discuss.elastic.co/u/dlumbrer)
#### Post date: [July 6, 2016, 1:37pm UTC](https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827/1 "2016-07-06T13:37:38Z")

</div>

Hi,

I have and error when I try to start a dev environment of Kibana 5 - alpha4.

Following the github instructions ([https://github.com/elastic/kibana/blob/5.0.0-alpha4/CONTRIBUTING.md](https://github.com/elastic/kibana/blob/5.0.0-alpha4/CONTRIBUTING.md)), when i go to localhost:5601, the console give me 2 errors and nothing is displayed on the screen (Discover, Visualize, Dashboard and Managment dont show anything).

The error:  
`https://localhost:5601/qtn/elasticsearch/.kibana/index-pattern/_search?fields= Failed to load resource: the server responded with a status of 400 (Bad Request)`

And:  
`Error: [illegal_argument_exception] The parameter [fields] is not longer supported, please use [stored_fields] to retrieve stored fields or _source filtering if the field is not stored at respond (elasticsearch.angular.js:65304) at checkRespForFailure (elasticsearch.angular.js:65263) at elasticsearch.angular.js:63781 at processQueue (angular.js:14745) at angular.js:14761 at Scope.$eval (angular.js:15989) at Scope.$digest (angular.js:15800) at Scope.$apply (angular.js:16097) at done (angular.js:10546) at completeRequest (angular.js:10744)`

And the screenshots:

 ![](https://us1.discourse-cdn.com/elastic/original/2X/6/6caa3658a175f9404efbf12554508e25718be0e0.png)  
 ![](https://us1.discourse-cdn.com/elastic/original/2X/c/c705fd442cbfd233313c4195bbbcae204416bb32.png)

Thanks.

---

<div class="post-metadata">

### Author: ![ppisljar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppisljar/32/11588_2.png) [@ppisljar](https://discuss.elastic.co/u/ppisljar)
#### Post date: [July 6, 2016, 2:24pm UTC](https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827/2 "2016-07-06T14:24:08Z")

</div>

Hi David,

i am having the same issue, but i can offer a workaround until this is fixed:

- download [elasticsearch alpha4 package](https://www.elastic.co/downloads/elasticsearch)
- run **bin/elasticsearch** to start it (unzip first ofcourse)
- now from your kibana dev folder start kibana with **npm start**

so basically you are skiping npm script which downloads latest elasticsearch version and starts it for you.

let me know if this works for you.

regards, Peter

---

<div class="post-metadata">

### Author: ![dlumbrer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dlumbrer/32/8323_2.png) [@dlumbrer](https://discuss.elastic.co/u/dlumbrer)
#### Post date: [July 6, 2016, 2:50pm UTC](https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827/3 "2016-07-06T14:50:53Z")

</div>

Thank you very much Peter, the problem has been solved!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:48pm UTC](https://discuss.elastic.co/t/error-starting-dev-environment-kibana5-alpha4/54827/4 "2017-07-06T13:48:06Z")

</div>


