# Error starting ES

**URL:** <https://discuss.elastic.co/t/error-starting-es/158774>\
**Category:** Elasticsearch\
**Created:** [November 29, 2018, 2:15pm UTC](https://discuss.elastic.co/t/error-starting-es/158774 "2018-11-29T14:15:50Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)\
**Post date:** [November 29, 2018, 2:15pm UTC](https://discuss.elastic.co/t/error-starting-es/158774/1 "2018-11-29T14:15:50Z")

</div>

I'm trying to start ES on solaris 11. With 6.2.2 version, no problem after some tweak, but with 6.5.1 version, i receive the following error:

Unrecognized option: -d  
Error: Could not create the Java Virtual Machine.  
Error: A fatal exception has occurred. Program will exit.

Can someone help me to solve? what it refers to "-d" option?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 27, 2018, 2:15pm UTC](https://discuss.elastic.co/t/error-starting-es/158774/2 "2018-12-27T14:15:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
