# Error starting filebeat reading CA certificate

**URL:** <https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [September 5, 2018, 1:48pm UTC](https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419 "2018-09-05T13:48:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jabu](https://avatars.discourse-cdn.com/v4/letter/j/f4b2a3/32.png) [@jabu](https://discuss.elastic.co/u/jabu)\
**Post date:** [September 5, 2018, 1:48pm UTC](https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419/1 "2018-09-05T13:48:23Z")

</div>

I'm unable to start filebeat  
This is the log file

```
2018-09-05T06:04:27-07:00 INFO Home path: [/usr/share/filebeat] Config path: [/etc/filebeat] Data path: [/var/lib/filebeat] Logs path: [/var/log/filebeat]
2018-09-05T06:04:27-07:00 INFO Setup Beat: filebeat; Version: 5.1.1
2018-09-05T06:04:27-07:00 CRIT Failed reading CA certificate: open /etc/pki/tls/certs/logstash-forwarder.crt: no such file or directory
2018-09-05T06:04:27-07:00 ERR failed to initialize logstash plugin as output: 1 error: open /etc/pki/tls/certs/logstash-forwarder.crt: no such file or directory reading /etc/pki/tls/certs/logstash-forwarder.crt
2018-09-05T06:04:27-07:00 CRIT Exiting: error initializing publisher: 1 error: open /etc/pki/tls/certs/logstash-forwarder.crt: no such file or directory reading /etc/pki/tls/certs/logstash-forwarder.crt

```

So if i understand correctly the program can't locate my logstash-forwarder.

this is my 'ls' output:

```
jabu@ubuntu: /etc/pki/tls/certs$ ls
logstash-forwarder.crt

```

Not sure what the problem is..

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [September 5, 2018, 2:15pm UTC](https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419/2 "2018-09-05T14:15:27Z")

</div>

Does Filebeat have access to the cert? What are the permissions of the file?

---

<div class="post-metadata">

**Author:** ![jabu](https://avatars.discourse-cdn.com/v4/letter/j/f4b2a3/32.png) [@jabu](https://discuss.elastic.co/u/jabu)\
**Post date:** [September 6, 2018, 12:54pm UTC](https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419/3 "2018-09-06T12:54:59Z")

</div>

-rw-r--r-- 1 root root 1241 Sep 5 06:25 /etc/pki/tls/certs/logstash-forwarder.crt

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 4, 2018, 12:55pm UTC](https://discuss.elastic.co/t/error-starting-filebeat-reading-ca-certificate/147419/4 "2018-10-04T12:55:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
