# \[ERROR\] timed out when collecting data

**URL:** <https://discuss.elastic.co/t/error-timed-out-when-collecting-data/146908>\
**Category:** Elasticsearch\
**Created:** [August 31, 2018, 7:06pm UTC](https://discuss.elastic.co/t/error-timed-out-when-collecting-data/146908 "2018-08-31T19:06:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![msina](https://avatars.discourse-cdn.com/v4/letter/m/a698b9/32.png) [@msina](https://discuss.elastic.co/u/msina)\
**Post date:** [August 31, 2018, 7:06pm UTC](https://discuss.elastic.co/t/error-timed-out-when-collecting-data/146908/1 "2018-08-31T19:06:55Z")

</div>

Hi ,

version: 6.3.0

We have installed trial version of ELK and it was working fine but recently we observed below error in ELK nodes and no data is showing in kibana dashboard.

In elk-master-node we are getting below errors along with the licesne expiry message since last couple of days

[2018-08-31T18:51:59,859][WARN][o.e.l.LicenseService] [elk-master-node] License [will expire] on [Friday, August 31, 2018].  
If you have a new license, please update it. Otherwise, please reach out to  
your support contact.  
Commercial plugins operate with reduced functionality on license expiration:  
security  
Cluster health, cluster stats and indices stats operations are blocked  
All data operations (read and write) continue to work  
watcher  
PUT / GET watch APIs are disabled, DELETE watch API continues to work  
Watches execute and write to the history  
The actions of the watches don't execute  
monitoring  
The agent will stop collecting cluster and indices metrics  
The agent will stop automatically cleaning indices older than [xpack.monitoring.history.duration]  
graph  
Graph explore APIs are disabled  
ml  
Machine learning APIs are disabled  
logstash  
Logstash will continue to poll centrally-managed pipelines  
deprecation  
Deprecation APIs are disabled  
upgrade  
Upgrade API is disabled  
sql  
SQL support is disabled  
rollup  
Creating and Starting rollup jobs will no longer be allowed.  
Stopping/Deleting existing jobs, RollupCaps API and RollupSearch continue to function.

[2018-08-31T18:52:26,761][ERROR][o.e.x.m.c.c.ClusterStatsCollector] [elk-master-node] collector [cluster\_stats] timed out when collecting data  
[2018-08-31T18:53:23,022][ERROR][o.e.x.m.c.i.IndexStatsCollector] [elk-master-node] collector [index-stats] timed out when collecting data

In data nodes getting the below message:

[2018-08-31T19:00:37,918][WARN][o.e.m.j.JvmGcMonitorService] [elk-data-node01] [gc][8066] overhead, spent [1.8s] collecting in the last [1.9s]  
[2018-08-31T19:00:39,410][ERROR][o.e.x.m.c.n.NodeStatsCollector] [elk-data-node01] collector [node\_stats] timed out when collecting data  
[2018-08-31T19:00:39,512][WARN][o.e.m.j.JvmGcMonitorService] [elk-data-node01] [gc][8067] overhead, spent [1.4s] collecting in the last [1.5s]

Cluster Status from master node:

{  
"\_nodes" : {  
"total" : 3,  
"successful" : 3,  
"failed" : 0  
},  
"cluster\_name" : "elk-logging-prod",  
"timestamp" : 1535741657925,  
"status" : "green",  
"indices" : {  
"count" : 172,  
"shards" : {  
"total" : 1432,  
"primaries" : 716,  
"replication" : 1.0,  
"index" : {  
"shards" : {  
"min" : 2,  
"max" : 10,  
"avg" : 8.325581395348838  
},  
"primaries" : {  
"min" : 1,  
"max" : 5,  
"avg" : 4.162790697674419  
},  
"replication" : {  
"min" : 1.0,  
"max" : 1.0,  
"avg" : 1.0  
}  
}  
},  
"docs" : {  
"count" : 146584946,  
"deleted" : 96934  
},  
"store" : {  
"size" : "105.6gb",  
"size\_in\_bytes" : 113435405019  
},  
"fielddata" : {  
"memory\_size" : "30.4kb",  
"memory\_size\_in\_bytes" : 31216,  
"evictions" : 0  
},  
"query\_cache" : {  
"memory\_size" : "163.2kb",  
"memory\_size\_in\_bytes" : 167168,  
"total\_count" : 66284,  
"hit\_count" : 5951,  
"miss\_count" : 60333,  
"cache\_size" : 59,  
"cache\_count" : 381,  
"evictions" : 322  
},  
"completion" : {  
"size" : "0b",  
"size\_in\_bytes" : 0  
},  
"segments" : {  
"count" : 12843,  
"memory" : "280.9mb",  
"memory\_in\_bytes" : 294616635,  
"terms\_memory" : "217.8mb",  
"terms\_memory\_in\_bytes" : 228436330,  
"stored\_fields\_memory" : "39.3mb",  
"stored\_fields\_memory\_in\_bytes" : 41305856,  
"term\_vectors\_memory" : "0b",  
"term\_vectors\_memory\_in\_bytes" : 0,  
"norms\_memory" : "8.3mb",  
"norms\_memory\_in\_bytes" : 8741824,  
"points\_memory" : "6.7mb",  
"points\_memory\_in\_bytes" : 7077349,  
"doc\_values\_memory" : "8.6mb",  
"doc\_values\_memory\_in\_bytes" : 9055276,  
"index\_writer\_memory" : "24.3mb",  
"index\_writer\_memory\_in\_bytes" : 25550466,  
"version\_map\_memory" : "696.2kb",  
"version\_map\_memory\_in\_bytes" : 712946,  
"fixed\_bit\_set" : "1.5mb",  
"fixed\_bit\_set\_memory\_in\_bytes" : 1610120,  
"max\_unsafe\_auto\_id\_timestamp" : 1535729108045,  
"file\_sizes" : { }  
}  
},  
"nodes" : {  
"count" : {  
"total" : 3,  
"data" : 2,  
"coordinating\_only" : 0,  
"master" : 1,  
"ingest" : 3  
},  
"versions" : [  
"6.3.0"  
],  
"os" : {  
"available\_processors" : 24,  
"allocated\_processors" : 24,  
"names" : [  
{  
"name" : "Linux",  
"count" : 3  
}  
],  
"mem" : {  
"total" : "70.4gb",  
"total\_in\_bytes" : 75689287680,  
"free" : "18.7gb",  
"free\_in\_bytes" : 20169138176,  
"used" : "51.7gb",  
"used\_in\_bytes" : 55520149504,  
"free\_percent" : 27,  
"used\_percent" : 73  
}  
},  
"process" : {  
"cpu" : {  
"percent" : 33  
},  
"open\_file\_descriptors" : {  
"min" : 384,  
"max" : 5880,  
"avg" : 4012  
}  
},  
"jvm" : {  
"max\_uptime" : "3.7h",  
"max\_uptime\_in\_millis" : 13350435,  
"versions" : [  
{  
"version" : "1.8.0\_161",  
"vm\_name" : "OpenJDK 64-Bit Server VM",  
"vm\_version" : "25.161-b14",  
"vm\_vendor" : "Oracle Corporation",  
"count" : 3  
}  
],  
"mem" : {  
"heap\_used" : "2.5gb",  
"heap\_used\_in\_bytes" : 2694126712,  
"heap\_max" : "3.8gb",  
"heap\_max\_in\_bytes" : 4153671680  
},  
"threads" : 493  
},  
"fs" : {  
"total" : "1.1tb",  
"total\_in\_bytes" : 1304314785792,  
"free" : "1tb",  
"free\_in\_bytes" : 1183926980608,  
"available" : "1tb",  
"available\_in\_bytes" : 1183926980608  
},  
"plugins" : [],  
"network\_types" : {  
"transport\_types" : {  
"security4" : 3  
},  
"http\_types" : {  
"security4" : 3  
}  
}  
}  
}  
[root@wielknews01 nodes]# curl -u elastic:Elastic@123 'localhost:9200'  
{  
"name" : "elk-master-node",  
"cluster\_name" : "elk-logging-prod",  
"cluster\_uuid" : "arew575AS2mNXNz-uWcMvQ",  
"version" : {  
"number" : "6.3.0",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "424e937",  
"build\_date" : "2018-06-11T23:38:03.357887Z",  
"build\_snapshot" : false,  
"lucene\_version" : "7.3.1",  
"minimum\_wire\_compatibility\_version" : "5.6.0",  
"minimum\_index\_compatibility\_version" : "5.0.0"  
},  
"tagline" : "You Know, for Search"  
}

Thanks  
Sina

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 28, 2018, 7:06pm UTC](https://discuss.elastic.co/t/error-timed-out-when-collecting-data/146908/2 "2018-09-28T19:06:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
