# Error to send data to Elasticsearch

**URL:** <https://discuss.elastic.co/t/error-to-send-data-to-elasticsearch/174313>\
**Category:** Logstash\
**Created:** [March 28, 2019, 11:01am UTC](https://discuss.elastic.co/t/error-to-send-data-to-elasticsearch/174313 "2019-03-28T11:01:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pad/32/16861_2.png) [@pad](https://discuss.elastic.co/u/pad)\
**Post date:** [March 28, 2019, 11:01am UTC](https://discuss.elastic.co/t/error-to-send-data-to-elasticsearch/174313/1 "2019-03-28T11:01:41Z")

</div>

Hi,

I'm using a Logstash (try 5.6.10 and currently 5.6.16) to execute sql queries on PostGresql and send the result to an ElasticSearch (5.6.10) but I've got this error when Logstash try to send to ES:

```
[2019-03-28T10:57:04,238][ERROR][logstash.outputs.elasticsearch] An unknown error occurred sending a bulk request to Elasticsearch. We will retry indefinitely {:error_message=>"Failed to load class 'org.postgresql.util.PGobject$Access4JacksonSerializer377dca2e': com.fasterxml.jackson.module.afterburner.ser.BeanPropertyAccessor", :error_class=>"LogStash::Json::GeneratorError", :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/json.rb:52:in `jruby_dump'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/http_client.rb:115:in `bulk'", "org/jruby/RubyArray.java:2414:in `map'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/http_client.rb:114:in `bulk'", "org/jruby/RubyArray.java:1613:in `each'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/http_client.rb:113:in `bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/common.rb:228:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/common.rb:119:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/common.rb:87:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-7.4.3-java/lib/logstash/outputs/elasticsearch/common.rb:38:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator_strategies/shared.rb:13:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/output_delegator.rb:49:in `multi_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:434:in `output_batch'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:433:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:381:in `worker_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:342:in `start_workers'"]}

```

The thing is that we're moving an existing process to a new server but we've got this error.  
On the "old" server, the process works but it wasn't me who perform the install so I try to redo it on the new server and I can't find why it doesn't work while it works with no issues on the old server.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 25, 2019, 11:01am UTC](https://discuss.elastic.co/t/error-to-send-data-to-elasticsearch/174313/2 "2019-04-25T11:01:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
