# Error toasts rendering in canvas pdfs

**URL:** <https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [September 11, 2023, 1:54pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742 "2023-09-11T13:54:54Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Krikkits](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krikkits/32/125421_2.png) [@Krikkits](https://discuss.elastic.co/u/Krikkits)\
**Post date:** [September 11, 2023, 1:54pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/1 "2023-09-11T13:54:54Z")

</div>

I saw that there was a github issue raised about it ([Kibana should stop rendering security warning on PDFs on unsecured cluster · Issue #82891 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/82891)) but I was wondering if there has been a fix or workaround since then? I am on a slightly older version of Elastic (v.7.17.3) as a docker image, which seems to still have this issue (see attached screenshot). Has this been resolved in newer versions?

 ![kibana error](https://us1.discourse-cdn.com/elastic/original/3X/6/b/6baccbacbdb2e96ab016a58ac459729413911c24.png)

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [September 11, 2023, 5:59pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/2 "2023-09-11T17:59:39Z")

</div>

Hi @Krikkits. Starting with v8.0, [Elastic comes with security on by default](https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-stack-security.html). So the second toast ("Your data is not secure") should no longer appear unless you explicitly disable security.

The first toast may still appear in the latest versions of Kibana if you have not configured the `server.publicBaseUrl` option in your kibana.yml file.

In either case, you should be able to click "Mute warning" and "Don't show again" respectively to hide future toasts. However, I believe these options are saved at the browser level, so they might appear again if you use a different browser or computer.

---

<div class="post-metadata">

**Author:** ![Krikkits](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krikkits/32/125421_2.png) [@Krikkits](https://discuss.elastic.co/u/Krikkits)\
**Post date:** [September 11, 2023, 6:17pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/3 "2023-09-11T18:17:25Z")

</div>

Thanks! Since it's imprinted into the generated PDF from the canvas, is there a way to mute these warnings somehow? I don't see a way to mute them before clicking "generate PDF". I don't actually get these warnings within Kibana (anymore).

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [September 11, 2023, 8:51pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/4 "2023-09-11T20:51:00Z")

</div>

Ohh, my apologies. I missed that it was happening in your reports. Have you configured the [`xpack.reporting.kibanaServer.hostname`](https://www.elastic.co/guide/en/kibana/7.17/reporting-settings-kb.html#reporting-kibana-server-settings) setting in your kibana.yml? Also, what is your `server.host` setting in kibana.yml?

---

<div class="post-metadata">

**Author:** ![Krikkits](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krikkits/32/125421_2.png) [@Krikkits](https://discuss.elastic.co/u/Krikkits)\
**Post date:** [September 12, 2023, 9:23am UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/5 "2023-09-12T09:23:21Z")

</div>

I believe they are not configured at the moment... It is a (unsecured) dev environment in Docker. Would I be correct in assuming that I should add `xpack.reporting.kibanaServer.hostname` and `server.host` as an environment variable set to the Kibana URL within our docker-compose? Our `ELASTICSEARCH_HOSTS` is set to the elastic image: `http://elastic-node:9200`, is that the same as server.host?

---

<div class="post-metadata">

**Author:** ![Krikkits](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krikkits/32/125421_2.png) [@Krikkits](https://discuss.elastic.co/u/Krikkits)\
**Post date:** [September 12, 2023, 1:29pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/7 "2023-09-12T13:29:01Z")

</div>

I solved it partially by adding in `SERVER_PUBLICBASEURL` but the security warning still renders within the PDF. Should I add in the other properties or is the only solution to enable security? See screenshot for the current look of my PDF.

 ![kibana error](https://us1.discourse-cdn.com/elastic/original/3X/0/0/00faa1e2e03ceda15ba709cf3f2c7a4051060353.png)

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [September 13, 2023, 5:12pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/8 "2023-09-13T17:12:25Z")

</div>

Hi @Krikkits. Enabling security on your cluster is probably the safest option.

I have not tried this, so I'm not sure if it will help. But maybe in "Advanced settings" [changing the `notifications:lifetime:warning`](https://www.elastic.co/guide/en/kibana/7.17/advanced-options.html#kibana-notification-settings) to a very small number will make the toast disappear more quickly. But this affects any notifications (not just this one), so you might experience some loss of information in other cases.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 11, 2023, 5:13pm UTC](https://discuss.elastic.co/t/error-toasts-rendering-in-canvas-pdfs/342742/9 "2023-10-11T17:13:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
