# ERROR: Too Many Requests - rejected execution of org.elasticsearch.transport.TransportService on EsThreadPoolExecutor

**URL:** <https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541>\
**Category:** Elasticsearch\
**Created:** [April 17, 2017, 7:55am UTC](https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541 "2017-04-17T07:55:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![agonzalez](https://avatars.discourse-cdn.com/v4/letter/a/ba8739/32.png) [@agonzalez](https://discuss.elastic.co/u/agonzalez)\
**Post date:** [April 17, 2017, 7:55am UTC](https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541/1 "2017-04-17T07:55:59Z")

</div>

during peak time once a day i may have +3000 clients indexing documents using NEST client and i see lot of connection fails with these errors. are both related? how can increase resources to avoid this? just have one node ES 5.2.

```
# ServerError: ServerError: 429Type: es_rejected_execution_exception Reason: "rejected execution of org.elasticsearch.transport.TransportService$7@16399044 on EsThreadPoolExecutor[index, queue capacity = 200, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@49aa71ba[Running, pool size = 4, active threads = 4, queued tasks = 200, completed tasks = 1521828]]"
# OriginalException: System.Net.WebException: The remote server returned an error: (429) Too Many Requests.

```

and also see this

```
# OriginalException: System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x40645d20 + 0x00197> in <filename unknown>:0 
  at System.Net.HttpWebRequest.GetResponse () <0x4063c200 + 0x00053> in <filename unknown>:0 
  at Elasticsearch.Net.HttpConnection.Request[TReturn] (Elasticsearch.Net.RequestData requestData) <0x4062a000 + 0x0029f> in <filename unknown>:0 
# Request:
<Request stream not captured or already read to completion by serializer. Set DisableDirectStreaming() on ConnectionSettings to force it to be set on the response.>
# Response:
<Response stream not captured or already read to completion by serializer. Set DisableDirectStreaming() on ConnectionSettings to force it to be set on the response.>
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 17, 2017, 8:03am UTC](https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541/2 "2017-04-17T08:03:29Z")

</div>

You will need to add more resources to your cluster.  
More nodes or increase the size of the one you have.

---

<div class="post-metadata">

**Author:** ![agonzalez](https://avatars.discourse-cdn.com/v4/letter/a/ba8739/32.png) [@agonzalez](https://discuss.elastic.co/u/agonzalez)\
**Post date:** [April 17, 2017, 8:17am UTC](https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541/3 "2017-04-17T08:17:01Z")

</div>

But the node has 4CPUs and 8GB RAM. maximum cpu usage is 60% during that peak time the rest of the day sever is idle and memory usage now is:

```
# free -m
              total used free shared buff/cache available
Mem: 7823 2936 481 3 4404 4605
Swap: 2047 161 1886

```

what should i increase? just memory? do i need to change any config settings to increase limits?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 15, 2017, 8:20am UTC](https://discuss.elastic.co/t/error-too-many-requests-rejected-execution-of-org-elasticsearch-transport-transportservice-on-esthreadpoolexecutor/82541/4 "2017-05-15T08:20:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
