# Error: Unable to complete saved object migrations for the \[.kibana\_task\_manager\] index

**URL:** <https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619>\
**Category:** Elasticsearch\
**Created:** [July 14, 2022, 8:45am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619 "2022-07-14T08:45:55Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![wonderland14](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wonderland14/32/102959_2.png) [@wonderland14](https://discuss.elastic.co/u/wonderland14)\
**Post date:** [July 14, 2022, 8:45am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/1 "2022-07-14T08:45:55Z")

</div>

Hi Elasticsearch Team, earlier I tried to close some indexes while performing Restore, and the Kibana turns down and not accessible. Can I have your help on this?

{"type":"log","@timestamp":"2022-07-14T16:36:17+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}  
{"type":"log","@timestamp":"2022-07-14T16:36:17+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"Starting saved objects migrations"}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana] INIT -\> OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT. took: 81ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] INIT -\> OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT. took: 82ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana] OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT -\> OUTDATED\_DOCUMENTS\_SEARCH\_READ. took: 30ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT -\> OUTDATED\_DOCUMENTS\_SEARCH\_READ. took: 31ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana] OUTDATED\_DOCUMENTS\_SEARCH\_READ -\> OUTDATED\_DOCUMENTS\_SEARCH\_CLOSE\_PIT. took: 14ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] OUTDATED\_DOCUMENTS\_SEARCH\_READ -\> OUTDATED\_DOCUMENTS\_SEARCH\_CLOSE\_PIT. took: 13ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana] OUTDATED\_DOCUMENTS\_SEARCH\_CLOSE\_PIT -\> UPDATE\_TARGET\_MAPPINGS. took: 5ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] OUTDATED\_DOCUMENTS\_SEARCH\_CLOSE\_PIT -\> UPDATE\_TARGET\_MAPPINGS. took: 6ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] UPDATE\_TARGET\_MAPPINGS -\> UPDATE\_TARGET\_MAPPINGS\_WAIT\_FOR\_TASK. took: 17ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["info","savedobjects-service"],"pid":59818,"message":"[.kibana] UPDATE\_TARGET\_MAPPINGS -\> UPDATE\_TARGET\_MAPPINGS\_WAIT\_FOR\_TASK. took: 46ms."}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["error","savedobjects-service"],"pid":59818,"message":"[.kibana\_task\_manager] Unexpected Elasticsearch ResponseError: statusCode: 400, method: GET, url: /\_tasks/lknaevIIRmqBEWw\_qYgDyg%3A24597983?wait\_for\_completion=true&timeout=60s error: [index\_closed\_exception]: closed,"}  
{"type":"log","@timestamp":"2022-07-14T16:36:19+10:00","tags":["fatal","root"],"pid":59818,"message":"Error: Unable to complete saved object migrations for the [.kibana\_task\_manager] index. Please check the health of your Elasticsearch cluster and try again. Unexpected Elasticsearch ResponseError: statusCode: 400, method: GET, url: /\_tasks/lknaevIIRmqBEWw\_qYgDyg%3A24597983?wait\_for\_completion=true&timeout=60s error: [index\_closed\_exception]: closed,\n at migrationStateActionMachine (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/core/server/saved\_objects/migrationsv2/migrations\_state\_action\_machine.js:164:13)\n at processTicksAndRejections (node:internal/process/task\_queues:96:5)\n at async Promise.all (index 1)\n at SavedObjectsService.start (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/core/server/saved\_objects/saved\_objects\_service.js:181:9)\n at Server.start (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/core/server/server.js:330:31)\n at Root.start (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/core/server/root/index.js:69:14)\n at bootstrap (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/core/server/bootstrap.js:120:5)\n at Command. (/opt/elasticsearch/elasticsearchkibana/dev/kibana-7.16.2-linux-x86\_64/src/cli/serve/serve.js:229:5)"}  
{"type":"log","@timestamp":"2022-07-14T16:36:20+10:00","tags":["error","savedobjects-service"],"pid":59818,"message":"[.kibana] Unexpected Elasticsearch ResponseError: statusCode: 400, method: GET, url: /\_tasks/lknaevIIRmqBEWw\_qYgDyg%3A24597991?wait\_for\_completion=true&timeout=60s error: [index\_closed\_exception]: closed,"}  
{"type":"log","@timestamp":"2022-07-14T16:36:21+10:00","tags":["info","plugins-system","standard"],"pid":59818,"message":"Stopping all plugins."}  
{"type":"log","@timestamp":"2022-07-14T16:36:21+10:00","tags":["info","plugins","monitoring","monitoring","kibana-monitoring"],"pid":59818,"message":"Monitoring stats collection is stopped"}  
{"type":"log","@timestamp":"2022-07-14T16:36:51+10:00","tags":["warning","plugins-system","standard"],"pid":59818,"message":""eventLog" plugin didn't stop in 30sec., move on to the next."}

FATAL Error: Unable to complete saved object migrations for the [.kibana\_task\_manager] index. Please check the health of your Elasticsearch cluster and try again. Unexpected Elasticsearch ResponseError: statusCode: 400, method: GET, url: /\_tasks/lknaevIIRmqBEWw\_qYgDyg%3A24597983?wait\_for\_completion=true&timeout=60s error: [index\_closed\_exception]: closed,

---

<div class="post-metadata">

**Author:** ![wonderland14](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wonderland14/32/102959_2.png) [@wonderland14](https://discuss.elastic.co/u/wonderland14)\
**Post date:** [July 14, 2022, 1:59pm UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/2 "2022-07-14T13:59:42Z")

</div>

It seems the Kibana is Corrupted because of closing the kibana security. Is it possible to use **POST /\_all/\_open**? If yes, how is it possible when the Kibana is not accessible?

---

<div class="post-metadata">

**Author:** ![wonderland14](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wonderland14/32/102959_2.png) [@wonderland14](https://discuss.elastic.co/u/wonderland14)\
**Post date:** [July 15, 2022, 9:27am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/3 "2022-07-15T09:27:47Z")

</div>

Solved by re-opening indices using the command curl -u "credential" -XPOST [localhost:9200/\_all/\_open](http://localhost:9200/_all/_open)

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [July 23, 2022, 8:03am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/4 "2022-07-23T08:03:26Z")

</div>

iam also facing same isuue, where can i run this command  
curl -u "credential" -XPOST [localhost:9200/\_all/\_open](http://localhost:9200/_all/_open)

---

<div class="post-metadata">

**Author:** ![wonderland14](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wonderland14/32/102959_2.png) [@wonderland14](https://discuss.elastic.co/u/wonderland14)\
**Post date:** [July 23, 2022, 10:34am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/5 "2022-07-23T10:34:55Z")

</div>

u can run this on command prompt 🙂

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [July 23, 2022, 11:25am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/6 "2022-07-23T11:25:51Z")

</div>

> [@mujtabah](#):
>
> curl -u "credential" -XPOST [localhost:9200/\_all/\_open](http://localhost:9200/_all/_open)

thanks. FYI if we run below command  
curl -u "crdetial\_of\_es" -XPOST [https://localhost:9200/\_all/\_open](https://localhost:9200/_all/_open)  
we get following error  
curl: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certif  
so this can be avoided by following command  
C:\Users\Administrator\>curl -u "crdetial\_of\_es" -XPOST [https://localhost:9200/\_all/\_open](https://localhost:9200/_all/_open) --ssl-no-revoke -L

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 20, 2022, 11:26am UTC](https://discuss.elastic.co/t/error-unable-to-complete-saved-object-migrations-for-the-kibana-task-manager-index/309619/7 "2022-08-20T11:26:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
