# Error(Unsupported Unknown Elasticsearch version 6.1.1) during Hive and elasticsearch connectivity

**URL:** https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [May 29, 2018, 10:19am UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657 "2018-05-29T10:19:07Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![sjain135](https://avatars.discourse-cdn.com/v4/letter/s/94ad74/32.png) [@sjain135](https://discuss.elastic.co/u/sjain135)
#### Post date: [May 29, 2018, 10:19am UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657/1 "2018-05-29T10:19:07Z")

</div>

Hi All,

I would like to push data into elastic search using hive. I am creating an external table using "org.elasticsearch.hadoop.hive.EsStorageHandler". When I am trying to insert data in this table, I am getting error as below-

Caused by: org.apache.hadoop.hive.ql.metadata.HiveException: org.apache.hadoop.hive.ql.metadata.HiveException: org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Unsupported/Unknown Elasticsearch version 6.1.1  
at org.apache.hadoop.hive.ql.exec.FileSinkOperator.createBucketFiles(FileSinkOperator.java:564)  
at org.apache.hadoop.hive.ql.exec.FileSinkOperator.process(FileSinkOperator.java:663)

Could you please help me , what I am missing for the connectivity?

Hadoop and elastic search versions are-  
Hadoop Version - Hadoop 2.7.0-mapr-1707  
Elastic Search Version - 6.1.1  
Jar used to connect -elasticsearch-hadoop-6.1.1.jar

---

<div class="post-metadata">

### Author: ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)
#### Post date: [May 30, 2018, 7:48pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657/2 "2018-05-30T19:48:18Z")

</div>

I would double check and make sure that there are no other versions of the ES-Hadoop jar on the classpath that might have snuck in. The only reason that you might be seeing this is if you are running on a version of ES-Hadoop in the 5.x line or lower.

---

<div class="post-metadata">

### Author: ![sjain135](https://avatars.discourse-cdn.com/v4/letter/s/94ad74/32.png) [@sjain135](https://discuss.elastic.co/u/sjain135)
#### Post date: [May 31, 2018, 12:51pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657/3 "2018-05-31T12:51:22Z")

</div>

Thanks James! Issue was related jar only!!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 28, 2018, 12:51pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-1-1-during-hive-and-elasticsearch-connectivity/133657/4 "2018-06-28T12:51:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
