# Error: Unsupported/Unknown Elasticsearch version 6.X.X

**URL:** https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [January 18, 2019, 6:34pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846 "2019-01-18T18:34:05Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![spagano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spagano/32/40136_2.png) [@spagano](https://discuss.elastic.co/u/spagano)
#### Post date: [January 18, 2019, 6:34pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846/1 "2019-01-18T18:34:05Z")

</div>

Hi,

I saw the same problem on too many places.

I have Hortonworks 2.6.4, Hadoop 2.7.3.2.6.4.0-91, Hive 1.2.1000.2.6.4.0-91, and, on the same host, I have installed Elasticsearch 6.4.3.

Then, I do the following

by command line:

1. wget -P /tmp [https://artifacts.elastic.co/downloads/elasticsearch-hadoop/elasticsearch-hadoop-6.4.3.zip;](https://artifacts.elastic.co/downloads/elasticsearch-hadoop/elasticsearch-hadoop-6.4.3.zip;)  
ok
2. unzip /tmp/elasticsearch-hadoop-6.4.3.zip -d /tmp;  
ok
3. hdfs dfs -copyFromLocal /tmp/elasticsearch-hadoop-6.4.3/dist/elasticsearch-hadoop-6.4.3.jar /tmp  
ok

On beeline o hive from dbeaver I do this:

1. ADD JAR hdfs:///tmp/elasticsearch-hadoop-6.4.3.jar;  
LIST JAR;  
ok

2. CREATE EXTERNAL TABLE artists (  
id BIGINT,  
name STRING,  
links STRUCT\<url:STRING, picture:STRING\>)  
STORED BY 'org.elasticsearch.hadoop.hive.EsStorageHandler'  
TBLPROPERTIES('es.nodes' = 'localhost' , 'es.resource' = 'radio/artists');  
ok

3. select \* from artists;  
wrong!

I GET "java.io.IOException: org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Unsupported/Unknown Elasticsearch version 6.4.3"

Why?? my ES is 6.4.3 and my ES-Hadoop 6.4.3

I saw the java code from elasticsearch-hadoop project and found this:

For InicializationUtils.java

if (!(esVersion.startsWith("1.") || esVersion.startsWith("2."))) {  
throw new EsHadoopIllegalArgumentException("Unsupported/Unknown Elasticsearch version " + esVersion);  
}

This is a validation that my ES has to be 1.x or 2.x????

What is wrong here??

Thanks in advance!!!

Sergio.

---

<div class="post-metadata">

### Author: ![spagano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spagano/32/40136_2.png) [@spagano](https://discuss.elastic.co/u/spagano)
#### Post date: [January 22, 2019, 12:08am UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846/2 "2019-01-22T00:08:35Z")

</div>

The problem was solved.

The roadmap was the following:

1. Use hive, no beeline.

2. Just copy elasticsearch-hadoop-6.4.3.jar to all data nodes and masters on /{HDP\_HOME}/hadoop/lib/ (hortonworks to me)

3. Create index and type on elasticsearch  
curl -X POST 'localhost:9200/bookindex/books' -H 'Content-Type: application/json' -d'  
{  
"bookId" : "A00-3",  
"author" : "Sankaran",  
"publisher" : "Mcgrahill",  
"name" : "how to get a job"  
}  
'

4. On hive always to do:  
hive\> add jar /usr/hdp/2.6.4.0-91/hadoop/lib/commons-httpclient-3.0.1.jar;  
hive\> add jar /usr/hdp/2.6.4.0-91/hadoop/lib/elasticsearch-hadoop-6.4.3.jar;  
hive\> CREATE EXTERNAL TABLE books ( bookId STRING, author STRING, publisher STRING, name STRING) STORED BY 'org.elasticsearch.hadoop.hive.EsStorageHandler' TBLPROPERTIES('es.nodes.wan.only'= 'TRUE', 'es.nodes.discovery' = 'false', 'es.nodes' = 'localhost', 'es.port' = '9200', 'es.resource' = 'bookindex/books');  
hive\> insert into books(bookid,author,publisher,name) values ('2','Pablo Neruda', 'Estrada','Poemas de Pablo Neruda');  
hive\> select count(\*) from books;  
hive\>select \* from books;  
OK

5. Check bookindex on elasticsearch!!

Enjoy!

Sergio.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 19, 2019, 12:08am UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846/3 "2019-02-19T00:08:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
