# Error: Unsupported/Unknown Elasticsearch version 6.X.X

**URL:** <https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [January 18, 2019, 6:34pm UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846 "2019-01-18T18:34:05Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![spagano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spagano/32/40136_2.png) [@spagano](https://discuss.elastic.co/u/spagano)\
**Post date:** [January 22, 2019, 12:08am UTC](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846/2 "2019-01-22T00:08:35Z")

</div>

The problem was solved.

The roadmap was the following:

1. Use hive, no beeline.

2. Just copy elasticsearch-hadoop-6.4.3.jar to all data nodes and masters on /{HDP\_HOME}/hadoop/lib/ (hortonworks to me)

3. Create index and type on elasticsearch  
curl -X POST 'localhost:9200/bookindex/books' -H 'Content-Type: application/json' -d'  
{  
"bookId" : "A00-3",  
"author" : "Sankaran",  
"publisher" : "Mcgrahill",  
"name" : "how to get a job"  
}  
'

4. On hive always to do:  
hive\> add jar /usr/hdp/2.6.4.0-91/hadoop/lib/commons-httpclient-3.0.1.jar;  
hive\> add jar /usr/hdp/2.6.4.0-91/hadoop/lib/elasticsearch-hadoop-6.4.3.jar;  
hive\> CREATE EXTERNAL TABLE books ( bookId STRING, author STRING, publisher STRING, name STRING) STORED BY 'org.elasticsearch.hadoop.hive.EsStorageHandler' TBLPROPERTIES('es.nodes.wan.only'= 'TRUE', 'es.nodes.discovery' = 'false', 'es.nodes' = 'localhost', 'es.port' = '9200', 'es.resource' = 'bookindex/books');  
hive\> insert into books(bookid,author,publisher,name) values ('2','Pablo Neruda', 'Estrada','Poemas de Pablo Neruda');  
hive\> select count(\*) from books;  
hive\>select \* from books;  
OK

5. Check bookindex on elasticsearch!!

Enjoy!

Sergio.

---

_[View the full topic](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846)._
