# Error using oracle module

**URL:** <https://discuss.elastic.co/t/error-using-oracle-module/275473>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [June 9, 2021, 3:58pm UTC](https://discuss.elastic.co/t/error-using-oracle-module/275473 "2021-06-09T15:58:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![LagartijaNick](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lagartijanick/32/90074_2.png) [@LagartijaNick](https://discuss.elastic.co/u/LagartijaNick)\
**Post date:** [June 9, 2021, 3:58pm UTC](https://discuss.elastic.co/t/error-using-oracle-module/275473/1 "2021-06-09T15:58:30Z")

</div>

Hi, I'm a newbie. Trying to use filebeat version 7.13.1, I've enabled two modules system and oracle like so: ./filebeat modules enable system oracle. I'm not changing either the system.yml or oracle.yml config files. I have in filebeat.yml:  
\< filebeat.inputs:

```auto
filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.

- type: log

  # Change to true to enable this input configuration.
  enabled: false
  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - /var/log/*.log

- type: log
  enabled: true
  paths:
    - /var/log/secure

- type: log
  enabled: true
  paths:
    - /app/oracle/admin/XXXXX/adump/*.aud

```

And the output set as:

```auto
# ------------------------------ Logstash Output -------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["xxxxx-x-xxxxx.xxx.xx:5044"]

```

When I run it I'm getting the following error messages:

```auto
2021-06-09T16:36:51.594+0100 INFO [monitoring] log/log.go:153 Uptime: 3.0477377s
2021-06-09T16:36:51.594+0100 INFO [monitoring] log/log.go:130 Stopping metrics logging.
2021-06-09T16:36:51.594+0100 INFO instance/beat.go:479 filebeat stopped.
2021-06-09T16:36:51.594+0100 ERROR instance/beat.go:989 Exiting: Failed to start crawler: creating module reloader failed: could not create module registry for filesets: error getting config for fileset oracle/database_audit: Error interpreting the template of the input: template: text:3:22: executing "text" at <.paths>: range can't iterate over /app/oracle/admin/XXXX/adump/*.aud
Exiting: Failed to start crawler: creating module reloader failed: could not create module registry for filesets: error getting config for fileset oracle/database_audit: Error interpreting the template of the input: template: text:3:22: executing "text" at <.paths>: range can't iterate over /app/oracle/admin/XXXX/adump/*.aud

```

It work as expected if I only use the system module and input, but not when I try and use the oracle one. Any suggestions please?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 7, 2021, 5:59pm UTC](https://discuss.elastic.co/t/error-using-oracle-module/275473/2 "2021-07-07T17:59:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
