# Error watcher input thought the Apache Reverse proxy

**URL:** https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347
**Category:** Elasticsearch
**Tags:** elastic-stack-alerting
**Created:** [December 4, 2015, 4:50am UTC](https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347 "2015-12-04T04:50:09Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dfr0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dfr0/32/6433_2.png) [@dfr0](https://discuss.elastic.co/u/dfr0)
#### Post date: [December 4, 2015, 4:50am UTC](https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347/1 "2015-12-04T04:50:09Z")

</div>

Hi all,

I try to configure a simple alert witch watcher about my cluster state

PUT /\_watcher/watch/cluster\_health\_watch  
{  
"trigger" : {  
"schedule" : { "interval" : "60s" }  
},  
"input" : {  
"http" : {  
"request" : {  
"host" : "myhost",  
"port" : 9200,  
"path" : "/\_cluster/health"  
}  
}  
},  
"condition" : {  
"compare" : {  
"ctx.payload.status" : { "eq" : "red" }  
}  
},  
"actions" : {  
"send\_email" : {  
"email" : {  
"to" : "l\*\*\*\*\*@\*\*\*\*\*\*\*",  
"subject" : "Chequear estado del cluster de Elasticsearch",  
"body" : "Cluster Elasticsearch caido"  
}  
}  
}  
}

[2015-12-04 04:44:24,414][ERROR][watcher.input.http] [Kamal] failed to execute [http] input for [org.elasticsearch.watcher.watch.Watch@5efed351]  
ScriptException[scripts of type [inline], operation [elasticsearch-watcher\_watch] and lang [xmustache] are disabled]  
at org.elasticsearch.script.ScriptService.compile(ScriptService.java:245)  
at org.elasticsearch.script.ScriptService.executable(ScriptService.java:442)  
at org.elasticsearch.watcher.support.init.proxy.ScriptServiceProxy.executable(ScriptServiceProxy.java:70)  
at org.elasticsearch.watcher.support.text.xmustache.XMustacheTextTemplateEngine.render(XMustacheTextTemplateEngine.java:50)  
at org.elasticsearch.watcher.support.http.HttpRequestTemplate.render(HttpRequestTemplate.java:123)  
at org.elasticsearch.watcher.input.http.ExecutableHttpInput.execute(ExecutableHttpInput.java:55)  
at org.elasticsearch.watcher.input.http.ExecutableHttpInput.execute(ExecutableHttpInput.java:40)  
at org.elasticsearch.watcher.execution.ExecutionService.executeInner(ExecutionService.java:350)  
at org.elasticsearch.watcher.execution.ExecutionService.execute(ExecutionService.java:274)  
at org.elasticsearch.watcher.execution.ExecutionService$WatchExecutionTask.run(ExecutionService.java:419)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [December 4, 2015, 5:00am UTC](https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347/2 "2015-12-04T05:00:21Z")

</div>

> [@dfr0](#):
>
> ScriptException[scripts of type [inline], operation [elasticsearch-watcher\_watch] and lang [xmustache] are disabled]

That's why, you need to enable scripting in your config.

---

<div class="post-metadata">

### Author: ![dfr0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dfr0/32/6433_2.png) [@dfr0](https://discuss.elastic.co/u/dfr0)
#### Post date: [December 4, 2015, 5:02am UTC](https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347/3 "2015-12-04T05:02:54Z")

</div>

Ah Ou!! than so much I wasn't focused

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:47pm UTC](https://discuss.elastic.co/t/error-watcher-input-thought-the-apache-reverse-proxy/36347/4 "2017-07-06T13:47:57Z")

</div>


