# Error: We Couldn´t activate monitoring

**URL:** <https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [January 18, 2021, 12:37pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427 "2021-01-18T12:37:12Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![wleandro](https://avatars.discourse-cdn.com/v4/letter/w/a88e4f/32.png) [@wleandro](https://discuss.elastic.co/u/wleandro)\
**Post date:** [January 18, 2021, 12:37pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/1 "2021-01-18T12:37:12Z")

</div>

Hi everyone

I need to learned about Activate Monitoring, but present error on display.

"We Couldn´t activate monitoring"

Is my first support on tecnology Elastic Search on Kibana.

Thank you for much.

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [January 18, 2021, 5:01pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/2 "2021-01-18T17:01:30Z")

</div>

> [@wleandro](#):
>
> "We Couldn´t activate monitoring"

Hi

Thank you for reporting your first issue. Can you provide more info- logs, screenshot , license level etc, to debug further.

Thanks  
Rashmi

---

<div class="post-metadata">

**Author:** ![wleandro](https://avatars.discourse-cdn.com/v4/letter/w/a88e4f/32.png) [@wleandro](https://discuss.elastic.co/u/wleandro)\
**Post date:** [January 18, 2021, 8:33pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/3 "2021-01-18T20:33:07Z")

</div>

Hi, Rashmi.

Our license is Good, but I have to configure the nodes according to the documentation.

> **[Monitoring settings in Kibana | Kibana Guide \[6.8\] | Elastic](https://www.elastic.co/guide/en/kibana/6.8/monitoring-settings-kb.html)**

Return soon;

---

<div class="post-metadata">

**Author:** ![wleandro](https://avatars.discourse-cdn.com/v4/letter/w/a88e4f/32.png) [@wleandro](https://discuss.elastic.co/u/wleandro)\
**Post date:** [January 19, 2021, 8:01pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/4 "2021-01-19T20:01:33Z")

</div>

Hi Hashmi

I was prepared for a basic test of ElasticSearch in version 6.4.3. But in the monitoring section there was a turn on monitoring button, when I clicked it, it activated monitoring correctly, but on the company server this button: Turn On Monitoring does not appear.

Follows the log and the screen prints I can't send gives an error when sending.

```auto
"
jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.doFlush(ExportBulk.java:170) [x-pack-monitoring-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.flushAndClose(ExportBulk.java:84) [x-pack-monitoring-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.close(ExportBulk.java:74) [x-pack-monitoring-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:196) [x-pack-monitoring-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.MonitoringService$MonitoringExecution$1.doRun(MonitoringService.java:258) [x-pack-monitoring-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_252]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_252]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:624) [elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_252]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_252]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at java.lang.Thread.run(Thread.java:748) [?:1.8.0_252]
Jan 19 09:13:17 li4309 elasticsearch[88363]: Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:156) ~[?:?]
Jan 19 09:13:17 li4309 elasticsearch[88363]: ... 51 more
Jan 19 09:13:17 li4309 elasticsearch[88363]: Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default_local]
Jan 19 09:13:17 li4309 elasticsearch[88363]: ... 50 more
Jan 19 09:13:17 li4309 elasticsearch[88363]: Caused by: java.lang.IllegalStateException: There are no ingest nodes in this cluster, unable to forward request to an ingest node.
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.action.ingest.IngestActionForwarder.randomIngestNode(IngestActionForwarder.java:58) ~[elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.action.ingest.IngestActionForwarder.forwardIngestRequest(IngestActionForwarder.java:51) ~[elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:136) ~[elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:85) ~[elasticsearch-6.4.3.jar:6.4.3]
Jan 19 09:13:17 li4309 elasticsearch[88363]: at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:167) ~[elasticsearch-6.4.3.jar:6.4.3]
"

```

---

<div class="post-metadata">

**Author:** ![wleandro](https://avatars.discourse-cdn.com/v4/letter/w/a88e4f/32.png) [@wleandro](https://discuss.elastic.co/u/wleandro)\
**Post date:** [January 22, 2021, 4:54pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/5 "2021-01-22T16:54:50Z")

</div>

Hi people,

Help me !

My production cluster is not just monitoring the test and approval, I have already compared it, I found nothing that is different from what is in production.

"Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:156) ~[?:?]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: ... 51 more  
Jan 22 13:45:58 li4309 elasticsearch[69666]: Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default\_local]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: ... 50 more  
Jan 22 13:45:58 li4309 elasticsearch[69666]: Caused by: java.lang.IllegalStateException: There are no ingest nodes in this cluster, unable to forward request to an ingest node.  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.action.ingest.IngestActionForwarder.randomIngestNode(IngestActionForwarder.java:58) ~[elasticsearch-6.4.3.jar:6.4.3]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.action.ingest.IngestActionForwarder.forwardIngestRequest(IngestActionForwarder.java:51) ~[elasticsearch-6.4.3.jar:6.4.3]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:136) ~[elasticsearch-6.4.3.jar:6.4.3]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:85) ~[elasticsearch-6.4.3.jar:6.4.3]  
Jan 22 13:45:58 li4309 elasticsearch[69666]: at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:167) ~[elasticsearc"

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [February 18, 2021, 5:33pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/6 "2021-02-18T17:33:39Z")

</div>

@chrisronline any inputs here?

---

<div class="post-metadata">

**Author:** ![wleandro](https://avatars.discourse-cdn.com/v4/letter/w/a88e4f/32.png) [@wleandro](https://discuss.elastic.co/u/wleandro)\
**Post date:** [February 18, 2021, 8:07pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/7 "2021-02-18T20:07:38Z")

</div>

I got it! Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 18, 2021, 8:08pm UTC](https://discuss.elastic.co/t/error-we-couldn-t-activate-monitoring/261427/8 "2021-03-18T20:08:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
