# Error when configure email account elasticseach.yml - Elastic Cloud

**URL:** <https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [January 8, 2021, 3:32pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560 "2021-01-08T15:32:56Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tornis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tornis/32/47522_2.png) [@Tornis](https://discuss.elastic.co/u/Tornis)\
**Post date:** [January 8, 2021, 3:32pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560/1 "2021-01-08T15:32:56Z")

</div>

Hello guys,

We have the problem when configuring SMTP more in ELastic Cloud SaaS Error when configure email account elasticseach.ymlfor sending alerts. When saving the configuration we get the following error:

Your changes cannot be applied  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.profile': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.auth': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.starttls.enable': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.host': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.port': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.user': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.profile': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.auth': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.starttls.enable': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.host': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.port': is not allowed  
Elasticsearch - 'xpack.notification.email.account.outlook\_account.smtp.user': is not allowed

We have already added and validated this email account as instructed by the documentation at the link below:

> **[Enable Alerting (Watcher) | Elasticsearch Service Documentation | Elastic](https://www.elastic.co/guide/en/cloud/current/ec-watcher.html#ec-watcher-whitelist)**

Can you help us?  
Sincerely

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [January 8, 2021, 6:46pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560/2 "2021-01-08T18:46:01Z")

</div>

Hi @Tornis

First we are not all guys 😉

Second have you looked at the new [Kibana Alerting Framework](https://www.elastic.co/guide/en/kibana/current/alerting-getting-started.html), pretty powerful and easy.

With respect to the emails and watcher in Elastic Cloud

The settings you are trying set are specifically not allowed in Elastic Cloud it is on the page you referenced above, the emails are sent / originated from the email services within elastic cloud.

_Specifically, [configuring email accounts](https://www.elastic.co/guide/en/elasticsearch/reference/7.10/actions-email.html#configuring-email) is not applicable to Elasticsearch Service._

So if you added the emails to the whitelist that you want to send the alerts to you will use that email(s) in your watcher action

 ![Screen Shot 2021-01-08 at 10.34.58 AM](https://us1.discourse-cdn.com/elastic/original/3X/6/f/6fe8c89b5250b4dc7d6acc5c05b0c75872dd530a.png)

Then you will use that in the watcher email actions

> **[Watcher email action | Elasticsearch Reference \[7.10\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.10/actions-email.html#configuring-email-actions)**

```
"actions" : {
  "send_email" : { 
    "email" : { 
      "to" : "alerts@mycompany.com", 
      "subject" : "Watcher Notification", 
      "body" : "{{ctx.payload.hits.total}} error logs found" 
    }
  }
}

```

Hope that helps... if you are doing fairly normal alerts take a look at the new framework, however watcher is still more advanced today though.

---

<div class="post-metadata">

**Author:** ![Tornis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tornis/32/47522_2.png) [@Tornis](https://discuss.elastic.co/u/Tornis)\
**Post date:** [January 8, 2021, 7:33pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560/3 "2021-01-08T19:33:51Z")

</div>

Hi @stephenb! Thanks for the English tips 🙂

About Elastic Cloud I'm using Watcher to generate reports and send them by email. So as I understand it, I don't have to worry about setting up an email gateway on the correct Elastic Cloud? Just inform the recipient that Elastic Cloud itself sends the email, is that it? Is my understanding correct?

Thanks!

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [January 8, 2021, 7:49pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560/4 "2021-01-08T19:49:50Z")

</div>

Yes ... Just add the whitelisted emails and then use them. it's been a while since I sent one.. so I don't remember the exact from ... I think you can set a from / reply to.. I would test it out.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 5, 2021, 7:49pm UTC](https://discuss.elastic.co/t/error-when-configure-email-account-elasticseach-yml-elastic-cloud/260560/5 "2021-02-05T19:49:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
