# Error when creating email alert in Cloud

**URL:** <https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring, elastic-stack-alerting\
**Created:** [December 9, 2020, 5:26pm UTC](https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168 "2020-12-09T17:26:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mc1392](https://avatars.discourse-cdn.com/v4/letter/m/57b2e6/32.png) [@mc1392](https://discuss.elastic.co/u/mc1392)\
**Post date:** [December 9, 2020, 5:26pm UTC](https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168/1 "2020-12-09T17:26:39Z")

</div>

When attempting to create an email alert I get the following error:

```
Action failed to run

The following error was found:
error sending email
Details:
139794888578880:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332: 

```

Support tells me I need to update`xpack.actions.allowedHosts`.

How can I get a view of the current value for this field using Kibana?

I can get the cluster settings by using:

> GET \_cluster/settings

---

<div class="post-metadata">

**Author:** ![JSkier](https://avatars.discourse-cdn.com/v4/letter/j/e47c2d/32.png) [@JSkier](https://discuss.elastic.co/u/JSkier)\
**Post date:** [December 11, 2020, 2:58pm UTC](https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168/2 "2020-12-11T14:58:03Z")

</div>

Also having this same issue on-prem. Interestingly, the old Watcher e-mail alerts work fine. Not sure if that setting goes into kibana.yml, but it could be applied with a PUT to the cluster. I'm looking into what works on my end, will report back. Also have a ticket open too.

---

<div class="post-metadata">

**Author:** ![JSkier](https://avatars.discourse-cdn.com/v4/letter/j/e47c2d/32.png) [@JSkier](https://discuss.elastic.co/u/JSkier)\
**Post date:** [December 11, 2020, 3:10pm UTC](https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168/3 "2020-12-11T15:10:10Z")

</div>

So, turns out this gets set in kibana.yml (reference below). I tried both the hostname and star, error still persists. Default is all (star).

`xpack.actions.allowedHosts: ["*"]`

Relevant article:

> **[Alerting and action settings in Kibana | Kibana Guide \[7.10\] | Elastic](https://www.elastic.co/guide/en/kibana/current/alert-action-settings-kb.html)**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 8, 2021, 3:10pm UTC](https://discuss.elastic.co/t/error-when-creating-email-alert-in-cloud/258168/4 "2021-01-08T15:10:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
