# Error when I'm launching logstash

**URL:** <https://discuss.elastic.co/t/error-when-im-launching-logstash/206561>\
**Category:** Logstash\
**Created:** [November 5, 2019, 9:20am UTC](https://discuss.elastic.co/t/error-when-im-launching-logstash/206561 "2019-11-05T09:20:54Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lgllrd](https://avatars.discourse-cdn.com/v4/letter/l/e8c25b/32.png) [@lgllrd](https://discuss.elastic.co/u/lgllrd)\
**Post date:** [November 5, 2019, 9:20am UTC](https://discuss.elastic.co/t/error-when-im-launching-logstash/206561/1 "2019-11-05T09:20:54Z")

</div>

Hi,  
I'm trying to launch logstash with my .conf file but it tell me an error that I don't understand :

> OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
> WARNING: An illegal reflective access operation has occurred  
> WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.8.0.jar) to field java.io.FileDescriptor.fd  
> WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
> WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
> WARNING: All illegal access operations will be denied in a future release  
> Thread.exclusive is deprecated, use Thread::Mutex  
> WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
> Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
> [WARN] 2019-11-05 09:44:43.533 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified  
> [INFO] 2019-11-05 09:44:43.568 [LogStash::Runner] runner - Starting Logstash {"logstash.version"=\>"7.4.1"}  
> [ERROR] 2019-11-05 09:44:45.887 [Converge PipelineAction::Create] agent - Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, {, } at line 24, column 27 (byte 454) after #Fichier de configuration de Logstash\n#Utilisation du plugin syslog\n\ninput {\n# udp {\n# #Configuration de deux paramètre : chemin et type\n# port =\> 514\n# type =\> syslog\n# }\n# tcp {\n# port =\> 514\n# type =\> syslog\n# }\n file {\n path=\>["/home/logstash/testdata.log"]\n sincedb\_path =\> "/dev/null"\n start\_position =\> "beginning\n }\n}\nfilter {\n#Dans le cas de multiple filtres, ils sont traités par ordre d'apparence\n}\noutput {\n# elasticsearch {hosts=\>["", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:in `compile\_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2584:in `map'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:153:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:26:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:326:in `block in converge\_state'"]}  
> [INFO] 2019-11-05 09:44:46.465 [Api Webserver] agent - Successfully started Logstash API endpoint {:port=\>9600}  
> [INFO] 2019-11-05 09:44:51.245 [LogStash::Runner] runner - Logstash shut down.

If someone understand

Thanks

> Blockquote

---

<div class="post-metadata">

**Author:** ![st3inbeiss](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/st3inbeiss/32/55332_2.png) [@st3inbeiss](https://discuss.elastic.co/u/st3inbeiss)\
**Post date:** [November 5, 2019, 9:24am UTC](https://discuss.elastic.co/t/error-when-im-launching-logstash/206561/2 "2019-11-05T09:24:25Z")

</div>

> [@lgllrd](#):
>
> Expected one of #, {, } at line 24

Look at line 24 of your config, my guess would be that there is a `{` without a friend!

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [November 5, 2019, 3:45pm UTC](https://discuss.elastic.co/t/error-when-im-launching-logstash/206561/3 "2019-11-05T15:45:09Z")

</div>

> [@lgllrd](#):
>
> start\_position =\> "beginning\n }\n}\nfilter {\n#Dans le cas de multiple filtres, ils sont traités par ordre d'apparence\n}\noutput {\n# elasticsearch {hosts=\>["

You do not have a closing quote on the value of start\_position, so it is consuming everything up to the opening quote of the hosts option on the elasticsearch output, then failing to parse.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 3, 2019, 3:48pm UTC](https://discuss.elastic.co/t/error-when-im-launching-logstash/206561/4 "2019-12-03T15:48:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
