# Error when installing license on ES 6.4.0

**URL:** https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745
**Category:** Elasticsearch
**Created:** [October 2, 2018, 5:50pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745 "2018-10-02T17:50:48Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![ccampbell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ccampbell/32/15320_2.png) [@ccampbell](https://discuss.elastic.co/u/ccampbell)
#### Post date: [October 2, 2018, 5:50pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/1 "2018-10-02T17:50:49Z")

</div>

I'm trying to install a non-production license on my monitoring cluster, but I'm getting the following error:  
_Please address the errors in your form._  
_Error encountered uploading license: Cannot install a [GOLD] license unless TLS is configured or security is disabled_

I've set **xpack.security.http.ssl.enabled: true** on the system, and have been running in secure mode for some time. Can anyone point me to the proper resolution?'

---

<div class="post-metadata">

### Author: ![fkelbert](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fkelbert/32/35762_2.png) [@fkelbert](https://discuss.elastic.co/u/fkelbert)
#### Post date: [October 2, 2018, 7:37pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/2 "2018-10-02T19:37:08Z")

</div>

Hi @ccampbell

According to the error message, you need to do either of the two:

- set `xpack.security.http.ssl.enabled: false`, or
- [configure TLS](https://www.elastic.co/guide/en/x-pack/current/ssl-tls.html)

---

<div class="post-metadata">

### Author: ![ccampbell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ccampbell/32/15320_2.png) [@ccampbell](https://discuss.elastic.co/u/ccampbell)
#### Post date: [October 3, 2018, 5:56pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/3 "2018-10-03T17:56:27Z")

</div>

I thought that I'd followed the correct instructions to enable TLS on this system. What is specifically being looked for that I'm missing? The documentation lists a number of steps to follow in setting up TLS. How do I verify if there is a failure occurring? Is the TLS status logged?

---

<div class="post-metadata">

### Author: ![ccampbell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ccampbell/32/15320_2.png) [@ccampbell](https://discuss.elastic.co/u/ccampbell)
#### Post date: [October 3, 2018, 8:01pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/4 "2018-10-03T20:01:13Z")

</div>

Submitted to Elastic Support.

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [October 4, 2018, 7:02am UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/5 "2018-10-04T07:02:27Z")

</div>

> [@ccampbell](#):
>
> I thought that I'd followed the correct instructions to enable TLS on this system.

From what you have shared it looks like you have only enabled TLS for the http layer, but you need to [enable TLS for the transport layer](https://www.elastic.co/guide/en/elasticsearch/reference/6.2/configuring-tls.html#tls-transport)  
The alternative is to disable security ( `xpack.security.enabled: false` )

---

<div class="post-metadata">

### Author: ![ccampbell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ccampbell/32/15320_2.png) [@ccampbell](https://discuss.elastic.co/u/ccampbell)
#### Post date: [October 5, 2018, 3:40pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/6 "2018-10-05T15:40:07Z")

</div>

Ioannis,

This was exactly the problem, I'd only completed the HTTP stack security configuration, not the transport layer. I've got that configured and it appears to be working correctly now.

Thanks -

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 2, 2018, 3:40pm UTC](https://discuss.elastic.co/t/error-when-installing-license-on-es-6-4-0/150745/7 "2018-11-02T15:40:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
