# Error when Reindex from 2.4.6 to 5.x (enabled) - Reindex helper

**URL:** https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996
**Category:** Elasticsearch
**Created:** [November 24, 2017, 9:24am UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996 "2017-11-24T09:24:42Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![juanito](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juanito/32/22927_2.png) [@juanito](https://discuss.elastic.co/u/juanito)
#### Post date: [November 24, 2017, 9:24am UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/1 "2017-11-24T09:24:42Z")

</div>

Hi  
I am migrating from 2.4.6 to 5.x, and I am using the migration tool ([https://github.com/elastic/elasticsearch-migration/tree/2.x](https://github.com/elastic/elasticsearch-migration/tree/2.x)), but when i using the Reindex Helper, its throw a error, see below:

“PUT [http://localhost:9200/index\_name](http://localhost:9200/index_name) failed with [400] Mapping definition for [SearchTab] has unsupported parameters: [enabled : false]: {} “

I am guessing that "enable" is not supported in 5,  
Do anyone know what is the right syntax then?

Thanks!

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [November 24, 2017, 9:44am UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/2 "2017-11-24T09:44:49Z")

</div>

What is the mapping you are trying to apply?

---

<div class="post-metadata">

### Author: ![juanito](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juanito/32/22927_2.png) [@juanito](https://discuss.elastic.co/u/juanito)
#### Post date: [November 24, 2017, 10:00am UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/3 "2017-11-24T10:00:08Z")

</div>

Hi @dadoonet  
Here is the mapping:

```
"Page": {
	"dynamic": "false",
	"properties": {
		"PageId": {
			"include_in_all": false,
			"index": "not_analyzed",
			"type": "string"
		},
		"SearchTab": {
			"type": "integer",
	---->	"enabled": false <----
		},
		"PageName": {
			"search_analyzer": "language_analyzer",
			"index_analyzer": "ngram_analyzer",
			"type": "string"
		},
		"Indexed": {
			"include_in_all": false,
			"index": "not_analyzed",
			"type": "date"
		}
	}
} 

```

this mapping is in the template.

Thanks

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [November 24, 2017, 1:57pm UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/4 "2017-11-24T13:57:09Z")

</div>

I think that this field was previously ignored.

Anyway, here is what you should do now IMO. This version is compatible with 6.0:

```auto
DELETE test
PUT test
{
  "mappings": {
    "Page": {
      "dynamic": "false",
      "properties": {
        "PageId": {
          "type": "keyword"
        },
        "SearchTab": {
          "type": "integer"
        },
        "PageName": {
          "search_analyzer": "language_analyzer",
          "analyzer": "ngram_analyzer",
          "type": "text"
        },
        "Indexed": {
          "type": "date"
        }
      }
    }
  }
}

```

---

<div class="post-metadata">

### Author: ![juanito](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juanito/32/22927_2.png) [@juanito](https://discuss.elastic.co/u/juanito)
#### Post date: [November 27, 2017, 12:40pm UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/5 "2017-11-27T12:40:34Z")

</div>

Thanks @dadoonet  
You where right, the field wasn't use.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 25, 2017, 12:40pm UTC](https://discuss.elastic.co/t/error-when-reindex-from-2-4-6-to-5-x-enabled-reindex-helper/108996/6 "2017-12-25T12:40:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
