# Error when running 7.12.1 on centos 7 in docker

**URL:** <https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508>\
**Category:** Elasticsearch\
**Created:** [April 28, 2021, 12:21pm UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508 "2021-04-28T12:21:31Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![WiseOwl](https://avatars.discourse-cdn.com/v4/letter/w/2bfe46/32.png) [@WiseOwl](https://discuss.elastic.co/u/WiseOwl)\
**Post date:** [April 28, 2021, 12:21pm UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508/1 "2021-04-28T12:21:31Z")

</div>

Hi,

Since the 7.12.1 update ES does not want to start in a docker container, running Centos 7. The systemd output is as such:

```auto
systemd-entrypoint[16341]: [0.001s][warning][os,container] Duplicate cpuset controllers detected. Picking /sys/fs/cgroup/cpuset, skipping /sys/fs/cgroup/cpuset.
systemd-entrypoint[16341]: [0.002s][warning][os,container] Duplicate cpuset controllers detected. Picking /sys/fs/cgroup/cpuset, skipping /sys/fs/cgroup/cpuset.
systemd-entrypoint[16341]: Error: Could not find or load main class [0.001s][warning][os,container]
systemd-entrypoint[16341]: Caused by: java.lang.ClassNotFoundException: [0/001s][warning][os,container]

```

Any help on this?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 29, 2021, 12:03am UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508/2 "2021-04-29T00:03:16Z")

</div>

That's not much to go on, what do the logs from the container show?

---

<div class="post-metadata">

**Author:** ![WiseOwl](https://avatars.discourse-cdn.com/v4/letter/w/2bfe46/32.png) [@WiseOwl](https://discuss.elastic.co/u/WiseOwl)\
**Post date:** [April 30, 2021, 7:35am UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508/3 "2021-04-30T07:35:42Z")

</div>

Hey, thanks for your reply

What logs would you require? This is the output of the elasticsearch daemon ran via systemd.

---

<div class="post-metadata">

**Author:** ![WiseOwl](https://avatars.discourse-cdn.com/v4/letter/w/2bfe46/32.png) [@WiseOwl](https://discuss.elastic.co/u/WiseOwl)\
**Post date:** [April 30, 2021, 8:40am UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508/4 "2021-04-30T08:40:28Z")

</div>

This issue has been resolved.  
If anyone might run into this as well, the problem was identified to be multiple mounts of the /sys/fs/cgroup folder. Done both in the build and execution phase, removing it from either resolves this issue!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 28, 2021, 8:40am UTC](https://discuss.elastic.co/t/error-when-running-7-12-1-on-centos-7-in-docker/271508/5 "2021-05-28T08:40:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
