# Error when setting up Alerts in Observability

**URL:** <https://discuss.elastic.co/t/error-when-setting-up-alerts-in-observability/339468>\
**Category:** Kibana\
**Tags:** elastic-stack-alerting\
**Created:** [July 27, 2023, 5:45pm UTC](https://discuss.elastic.co/t/error-when-setting-up-alerts-in-observability/339468 "2023-07-27T17:45:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![elastic12](https://avatars.discourse-cdn.com/v4/letter/e/d78d45/32.png) [@elastic12](https://discuss.elastic.co/u/elastic12)\
**Post date:** [July 27, 2023, 5:45pm UTC](https://discuss.elastic.co/t/error-when-setting-up-alerts-in-observability/339468/1 "2023-07-27T17:45:25Z")

</div>

I am setting up an Log Threshold alert using index connector. I followed all the steps shown in the documentation  
[Index connector and action | Kibana Guide [8.6] | Elastic](https://www.elastic.co/guide/en/kibana/8.6/index-action-type.html#define-index-ui)

and I am getting an error shown below "Rule registry writing is disabled due to an error during Rule Data Client Initialization."

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/4/e480926c5da375d9e42783bea05b9765e0dea0dc.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 24, 2023, 5:45pm UTC](https://discuss.elastic.co/t/error-when-setting-up-alerts-in-observability/339468/2 "2023-08-24T17:45:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
