# Error when start the elastics services

**URL:** <https://discuss.elastic.co/t/error-when-start-the-elastics-services/349682>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring, elastic-stack-security, elastic-stack-alerting, runtime-fields\
**Created:** [December 19, 2023, 10:11pm UTC](https://discuss.elastic.co/t/error-when-start-the-elastics-services/349682 "2023-12-19T22:11:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Antonio\_Sanchez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/antonio_sanchez/32/128012_2.png) [@Antonio\_Sanchez](https://discuss.elastic.co/u/Antonio_Sanchez)\
**Post date:** [December 19, 2023, 10:11pm UTC](https://discuss.elastic.co/t/error-when-start-the-elastics-services/349682/1 "2023-12-19T22:11:43Z")

</div>

Hello

I'm installing a elastics services on a server ubuntu 22.4 but when I start the services I recibet the next error:

```auto
[sudo] password for toor: 
Job for elasticsearch.service failed because the control process exited with error code.
See "systemctl status elasticsearch.service" and "journalctl -xeu elasticsearch.service" for details.

```

this is the code

```auto
toor@monitoreodered:~$ sudo systemctl start elasticsearch

```

this is the log:

```auto
× elasticsearch.service - Elasticsearch
     Loaded: loaded (/lib/systemd/system/elasticsearch.service; enabled; vendo>
     Active: failed (Result: exit-code) since Tue 2023-12-19 22:02:10 UTC; 8mi>
       Docs: https://www.elastic.co
    Process: 4513 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p>
   Main PID: 4513 (code=exited, status=1/FAILURE)
        CPU: 4.919s

Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: ^
Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: at org.yaml.s>
Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: at org.yaml.s>
Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: at org.yaml.s>
Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: at com.faster>
Dec 19 22:02:10 monitoreodered systemd-entrypoint[4513]: ... 13 more
Dec 19 22:02:10 monitoreodered systemd[1]: elasticsearch.service: Main process>
Dec 19 22:02:10 monitoreodered systemd[1]: elasticsearch.service: Failed with >
Dec 19 22:02:10 monitoreodered systemd[1]: Failed to start Elasticsearch.
Dec 19 22:02:10 monitoreodered systemd[1]: elasticsearch.service: Consumed 4.9>
lines 1-18/18 (END)

```

```auto
An ExecStart= process belonging to unit elasticsearch.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Dec 19 22:02:10 monitoreodered systemd[1]: elasticsearch.service: Failed with >
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: http://www.ubuntu.com/support
░░ 
░░ The unit elasticsearch.service has entered the 'failed' state with result '>
Dec 19 22:02:10 monitoreodered systemd[1]: Failed to start Elasticsearch.
░░ Subject: A start job for unit elasticsearch.service has failed
░░ Defined-By: systemd
░░ Support: http://www.ubuntu.com/support
░░ 
░░ A start job for unit elasticsearch.service has finished with a failure.
░░ 
░░ The job identifier is 3012 and the job result is failed.
Dec 19 22:02:10 monitoreodered systemd[1]: elasticsearch.service: Consumed 4.9>
░░ Subject: Resources consumed by unit runtime
░░ Defined-By: systemd
░░ Support: http://www.ubuntu.com/support
░░ 
░░ The unit elasticsearch.service completed and consumed the indicated resourc>
lines 773-795/795 (END)

```

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [December 19, 2023, 10:54pm UTC](https://discuss.elastic.co/t/error-when-start-the-elastics-services/349682/2 "2023-12-19T22:54:28Z")

</div>

You have a systemd error, you need to check the `/var/log/syslog` file for any hint why the service failed to start.

Try to start it again to get fresh logs and look at the mentioned file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 16, 2024, 10:54pm UTC](https://discuss.elastic.co/t/error-when-start-the-elastics-services/349682/3 "2024-01-16T22:54:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
