# Error while building the elasticsearch docker image with search guard

**URL:** <https://discuss.elastic.co/t/error-while-building-the-elasticsearch-docker-image-with-search-guard/198326>\
**Category:** Elasticsearch\
**Created:** [September 5, 2019, 11:38pm UTC](https://discuss.elastic.co/t/error-while-building-the-elasticsearch-docker-image-with-search-guard/198326 "2019-09-05T23:38:10Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vampire](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vampire/32/41648_2.png) [@vampire](https://discuss.elastic.co/u/vampire)\
**Post date:** [September 5, 2019, 11:38pm UTC](https://discuss.elastic.co/t/error-while-building-the-elasticsearch-docker-image-with-search-guard/198326/1 "2019-09-05T23:38:10Z")

</div>

I am trying to build the Docker image with search guard 36.0.0 on elasticsearch 7.1.1. The Dockerfile looks like this:

```auto
# https://github.com/elastic/elasticsearch-docker
FROM docker.elastic.co/elasticsearch/elasticsearch:7.1.1

COPY bin/ bin/
# COPY config/sg/ config/sg/
COPY config/elasticsearch.yml /usr/share/elasticsearch/config/elasticsearch.yml
COPY config/sg/CN=elasticsearch-0.elasticsearch-keystore.jks config/sg/CN=elasticsearch-0.elasticsearch-keystore.jks 
COPY config/sg/truststore.jks config/sg/truststore.jks 

# Search Guard plugin

RUN elasticsearch-plugin install --batch com.floragunn:search-guard-7:7.1.1-36.0.0 \
	&& chmod +x plugins/search-guard-7/tools/*.sh \
	&& chown -R elasticsearch config/sg/ \
	&& chmod -R go= config/sg/ 

# sgadmin and other third-party tools require a valid Java home
ENV JAVA_HOME /usr/share/elasticsearch/jdk
EXPOSE 9200 9300

COPY config/sg/CN=sgadmin-keystore.jks plugins/search-guard-7/tools
COPY config/sg/truststore.jks plugins/search-guard-7/tools
COPY config/sg/CN=elasticsearch-0.elasticsearch-keystore.jks plugins/search-guard-7/tools

RUN chmod 755 plugins/search-guard-7/tools/sgadmin.sh \
	&& plugins/search-guard-7/tools/sgadmin.sh \
	-ts plugins/search-guard-7/tools/truststore.jks \
	-tspass eb78abdeb3126eb91afb \
	-ks plugins/search-guard-7/tools/CN=sgadmin-keystore.jks \
	-kspass 6d889f0039997d6dbdb3 \
	-nhnv \
	-icl \
	-cd plugins/search-guard-7/sgconfig/ 

```

it always give me this error when It tries to initialize the search guard

```auto
ERR: Seems there is no Elasticsearch running on localhost:9300 - Will exit

```

I have tried to sleep 10 seconds before the initialization step, I still got the same error.

However, the image is built without the initialization step, and I can ssh into the running container to initialize the search guard.

But I really want to include this step into the Dockerfile. Have no clue how to fix this.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 3, 2019, 11:38pm UTC](https://discuss.elastic.co/t/error-while-building-the-elasticsearch-docker-image-with-search-guard/198326/2 "2019-10-03T23:38:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
