# Error while migrating to es 5.4 from 1.4

**URL:** <https://discuss.elastic.co/t/error-while-migrating-to-es-5-4-from-1-4/118193>\
**Category:** Elasticsearch\
**Created:** [February 2, 2018, 9:27am UTC](https://discuss.elastic.co/t/error-while-migrating-to-es-5-4-from-1-4/118193 "2018-02-02T09:27:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nitish\_Goyal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nitish_goyal/32/54988_2.png) [@Nitish\_Goyal](https://discuss.elastic.co/u/Nitish_Goyal)\
**Post date:** [February 2, 2018, 9:27am UTC](https://discuss.elastic.co/t/error-while-migrating-to-es-5-4-from-1-4/118193/1 "2018-02-02T09:27:39Z")

</div>

Migrating the cluster from es 1.4 to 5.4.  
Getting the below error frequently while migrating  
Caused by: org.elasticsearch.common.util.concurrent.UncategorizedExecutionException: Failed execution  
at org.elasticsearch.action.support.AdapterActionFuture.rethrowExecutionException(AdapterActionFuture.java:92)  
at org.elasticsearch.action.support.AdapterActionFuture.actionGet(AdapterActionFuture.java:50)  
at org.elasticsearch.action.bulk.BulkProcessor.execute(BulkProcessor.java:313)  
... 13 common frames omitted  
Caused by: java.util.concurrent.ExecutionException: java.io.IOException: request retries exceeded max retry timeout [120000]  
at org.elasticsearch.common.util.concurrent.BaseFuture$Sync.getValue(BaseFuture.java:288)  
at org.elasticsearch.common.util.concurrent.BaseFuture$Sync.get(BaseFuture.java:275)  
at org.elasticsearch.common.util.concurrent.BaseFuture.get(BaseFuture.java:113)  
at org.elasticsearch.action.support.AdapterActionFuture.actionGet(AdapterActionFuture.java:45)  
... 14 common frames omitted  
Caused by: java.io.IOException: request retries exceeded max retry timeout [120000]  
at org.elasticsearch.client.rest.support.InternalRestClient$1.retryIfPossible(InternalRestClient.java:333)  
at org.elasticsearch.client.rest.support.InternalRestClient$1.failed(InternalRestClient.java:321)  
at org.elasticsearch.client.rest.support.InternalRestClientBuilder$2.execute(InternalRestClientBuilder.java:377)  
at org.elasticsearch.client.rest.support.InternalRestClient.performRequestAsync(InternalRestClient.java:354)  
at org.elasticsearch.client.rest.support.InternalRestClient.performRequestAsync(InternalRestClient.java:247)  
at org.elasticsearch.client.rest.support.InternalRestClient.performRequest(InternalRestClient.java:218)  
at org.elasticsearch.client.rest.support.InternalRestClient.performRequest(InternalRestClient.java:185)  
at org.elasticsearch.client.rest.support.RestExecuteUtil.execute(RestExecuteUtil.java:61)  
at org.elasticsearch.client.rest.RestClient.execute(RestClient.java:105)  
at org.elasticsearch.client.rest.RestClient.execute(RestClient.java:99)  
at org.elasticsearch.client.support.AbstractClient.bulk(AbstractClient.java:159)

I am using the bulk api call to migrate the docs and keeping the bulk size as 1000. This error usually comes after running migration for few hours  
Index stats data : 150GB, doc count : 90 million, shards : 16, nodes : 2

Any help on this would be highly appreciated

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 2, 2018, 9:27am UTC](https://discuss.elastic.co/t/error-while-migrating-to-es-5-4-from-1-4/118193/2 "2018-03-02T09:27:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
