# Error while running multiple pipelines in logstash on centOS 7

**URL:** <https://discuss.elastic.co/t/error-while-running-multiple-pipelines-in-logstash-on-centos-7/182423>\
**Category:** Logstash\
**Created:** [May 23, 2019, 12:00pm UTC](https://discuss.elastic.co/t/error-while-running-multiple-pipelines-in-logstash-on-centos-7/182423 "2019-05-23T12:00:21Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Vicky\_S](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vicky_s/32/60764_2.png) [@Vicky\_S](https://discuss.elastic.co/u/Vicky_S)\
**Post date:** [May 23, 2019, 12:00pm UTC](https://discuss.elastic.co/t/error-while-running-multiple-pipelines-in-logstash-on-centos-7/182423/1 "2019-05-23T12:00:22Z")

</div>

Hi, Iam running multiple pipelines on centOS 7. I'm moving data from mySQl to elasticsearch. One or two pipelines seem to work fine but when I run more than three pipelines some pipelines get aborted showing error messages like

\<[2019-05-23T16:59:59,153][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-05-23T17:00:06,253][INFO][logstash.inputs.jdbc] (4.712866s) SELECT \* FROM vtigerfinal WHERE DATE(modifiedtime) = DATE(NOW()) AND modifiedtime \>0 order by modifiedtime  
[2019-05-23T17:00:07,222][INFO][logstash.inputs.jdbc] (5.685583s) SELECT \* FROM vicidial\_closer\_log WHERE DATE(call\_date) = DATE(NOW()) AND call\_date \>0  
[2019-05-23T17:00:09,473][INFO][logstash.inputs.jdbc] (7.942491s) SELECT \* FROM vicidial\_agent\_log WHERE DATE(event\_time)=DATE(NOW()) AND event\_time \>0  
[2019-05-23T17:00:52,470][WARN][logstash.runner] SIGTERM received. Shutting down.  
[2019-05-23T17:00:53,655][INFO][logstash.pipeline] Pipeline has terminated {:pipeline\_id=\>"closer", :thread=\>"#\<Thread:0x3765e097@/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:48 run\>"}  
[2019-05-23T17:00:53,656][INFO][logstash.pipeline] Pipeline has terminated {:pipeline\_id=\>"vtiger", :thread=\>"#\<Thread:0x512565a5 run\>"}  
[2019-05-23T17:00:53,916][INFO][logstash.pipeline] Pipeline has terminated {:pipeline\_id=\>"vicidialagent", :thread=\>"#\<Thread:0xd06c39a@/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:47 run\>"}  
[2019-05-23T17:00:53,921][INFO][logstash.runner] Logstash shut down.\>

Should I change something in logstash.yml? I cannot find a proper solution. Please help.

---

<div class="post-metadata">

**Author:** ![Vicky\_S](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vicky_s/32/60764_2.png) [@Vicky\_S](https://discuss.elastic.co/u/Vicky_S)\
**Post date:** [June 6, 2019, 6:38am UTC](https://discuss.elastic.co/t/error-while-running-multiple-pipelines-in-logstash-on-centos-7/182423/2 "2019-06-06T06:38:48Z")

</div>

Still unable to find a solution.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 4, 2019, 6:38am UTC](https://discuss.elastic.co/t/error-while-running-multiple-pipelines-in-logstash-on-centos-7/182423/3 "2019-07-04T06:38:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
