# Error while starting logstash 8.3.1

**URL:** <https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811>\
**Category:** Logstash\
**Created:** [July 4, 2022, 11:54am UTC](https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811 "2022-07-04T11:54:40Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Thuunder7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thuunder7/32/97482_2.png) [@Thuunder7](https://discuss.elastic.co/u/Thuunder7)\
**Post date:** [July 4, 2022, 11:54am UTC](https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811/1 "2022-07-04T11:54:40Z")

</div>

Hello guys,

Recently i upgraded my logstash instance from 7.x to 8.3.1.  
But now when i try to start the logstash service, i get the following log:

> [ERROR][logstash.runner] Logging configuration uses Script log appender or filter with Javascript, which is no longer supported.

I googled this error but i still don't have an answer for this error.  
Any guesses?

Thank you

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [July 4, 2022, 4:36pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811/2 "2022-07-04T16:36:04Z")

</div>

> [@Thuunder7](#):
>
> Logging configuration uses Script log appender or filter with Javascript, which is no longer supported

logstash no longer allows Javascript Script filters. Not sure why. The log4j2.properties [is scanned](https://github.com/elastic/logstash/blob/120648abe4ddbe824048204babeb9ebefd3492aa/logstash-core/lib/logstash/runner.rb#L295) for "script.language=JavaScript" and if logstash finds it then it logs that error and fails to start. [This PR](https://github.com/elastic/logstash/pull/12512) implemented that.

---

<div class="post-metadata">

**Author:** ![Thuunder7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/thuunder7/32/97482_2.png) [@Thuunder7](https://discuss.elastic.co/u/Thuunder7)\
**Post date:** [July 6, 2022, 10:01pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811/3 "2022-07-06T22:01:21Z")

</div>

I got the issue fixed.  
I will update the post soon.

Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 3, 2022, 10:01pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash-8-3-1/308811/4 "2022-08-03T22:01:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
