# Error while starting Logstash

**URL:** <https://discuss.elastic.co/t/error-while-starting-logstash/105268>\
**Category:** Logstash\
**Created:** [October 25, 2017, 2:40pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268 "2017-10-25T14:40:49Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![yoga-sara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yoga-sara/32/27541_2.png) [@yoga-sara](https://discuss.elastic.co/u/yoga-sara)\
**Post date:** [October 25, 2017, 2:40pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268/1 "2017-10-25T14:40:49Z")

</div>

Hello,  
I'm having ELK 5.6.2.My environment like below,

FileBeat(Machine A) =\> Logstash (Machine B) =\> Elasticsearch (Machine B) =\> Kibana (Machine B)

I have configured Logstash as output.

> #----------------------------- Logstash output ---------------------------------  
> output.logstash:  
> enabled: true  
> hosts: ["IP of Machine B:5044"]  
> ssl.enabled: false

My Logstash pipeline like,

> input {  
> beats {  
> port =\> 5044  
> ssl =\> false  
> }  
> }
> 
> output {  
> elasticsearch {  
> hosts =\> ["IP of Machine B:9200"]  
> sniffing =\> true  
> manage\_template =\> false  
> index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
> document\_type =\> "%{[@metadata][type]}"  
> }  
> }

My Logstash.yml like,

> # ------------ Node identity ------------
> 
> node.name: QALogParser
> 
> # ------------ Metrics Settings --------------
> 
> http.host: "IP of Machine B"

While I start logstash I got below error,

> ][INFO][logstash.inputs.beats] Beats inputs: Starting input listener {:address=\>"0.0.0.0:5044"}  
> [2017-10-25T19:45:33,594][INFO][logstash.pipeline] Pipeline main started  
> [2017-10-25T19:45:33,715][INFO][org.logstash.beats.Server] Starting server on port: 5044  
> [2017-10-25T19:45:33,862][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<Errno::EADDRNOTAVAIL: Cannot assign requested address - bind - Cannot assign requested address\>, :backtrace=\>["org/jruby/ext/socket/RubyTCPServer.java:118:in `initialize'", "org/jruby/RubyIO.java:871:in `new'", "/opt/Logger/Logstash/vendor/bundle/jruby/1.9/gems/puma-2.16.0-java/lib/puma/binder.rb:234:in `add_tcp_listener'", "(eval):2:in `add\_tcp\_listener'", "/opt/Logger/Logstash/logstash-core/lib/logstash/webserver.rb:88:in `start_webserver'", "/opt/Logger/Logstash/logstash-core/lib/logstash/webserver.rb:44:in `run'", "org/jruby/RubyRange.java:476:in `each'", "org/jruby/RubyEnumerable.java:971:in `each\_with\_index'", "/opt/Logger/Logstash/logstash-core/lib/logstash/webserver.rb:39:in `run'", "/opt/Logger/Logstash/logstash-core/lib/logstash/agent.rb:222:in `start\_webserver'"]}

Any suggestions?Thanks in advance.

---

<div class="post-metadata">

**Author:** ![Jack\_Judge](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jack_judge/32/85499_2.png) [@Jack\_Judge](https://discuss.elastic.co/u/Jack_Judge)\
**Post date:** [October 25, 2017, 6:07pm UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268/2 "2017-10-25T18:07:35Z")

</div>

Obvious question, is there anything else listening on that port number ?

netstat -anlp | grep 5044

---

<div class="post-metadata">

**Author:** ![yoga-sara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yoga-sara/32/27541_2.png) [@yoga-sara](https://discuss.elastic.co/u/yoga-sara)\
**Post date:** [October 26, 2017, 3:38am UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268/3 "2017-10-26T03:38:40Z")

</div>

Hi Jack,  
5044 port not listening.

---

<div class="post-metadata">

**Author:** ![yoga-sara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yoga-sara/32/27541_2.png) [@yoga-sara](https://discuss.elastic.co/u/yoga-sara)\
**Post date:** [October 26, 2017, 7:55am UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268/4 "2017-10-26T07:55:07Z")

</div>

Issue solved 🙂 while I configure my pipeline like below,

> input {  
> beats {  
> host =\> "Private IP of Machine B"  
> port =\> 5044  
> ssl =\> false  
> }  
> }

IP made an issue .

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 23, 2017, 7:55am UTC](https://discuss.elastic.co/t/error-while-starting-logstash/105268/5 "2017-11-23T07:55:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
