# Error while using ./elasticsearch-node repurpose tool

**URL:** <https://discuss.elastic.co/t/error-while-using-elasticsearch-node-repurpose-tool/338807>\
**Category:** Elasticsearch\
**Created:** [July 19, 2023, 3:43pm UTC](https://discuss.elastic.co/t/error-while-using-elasticsearch-node-repurpose-tool/338807 "2023-07-19T15:43:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hlcxpl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hlcxpl/32/123290_2.png) [@hlcxpl](https://discuss.elastic.co/u/hlcxpl)\
**Post date:** [July 19, 2023, 3:43pm UTC](https://discuss.elastic.co/t/error-while-using-elasticsearch-node-repurpose-tool/338807/1 "2023-07-19T15:43:23Z")

</div>

i got this error while using /usr/share/elasticsearch/elasticsearch-node repurpose to set my master node only for master

```auto
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "unable to authenticate user [elastic] for REST request [/_cluster/health?pretty]",
        "header" : {
          "WWW-Authenticate" : [
            "Basic realm=\"security\" charset=\"UTF-8\"",
            "Bearer realm=\"security\"",
            "ApiKey"
          ]
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "unable to authenticate user [elastic] for REST request [/_cluster/health?pretty]",
    "header" : {
      "WWW-Authenticate" : [
        "Basic realm=\"security\" charset=\"UTF-8\"",
        "Bearer realm=\"security\"",
        "ApiKey"
      ]
    }
  },
  "status" : 401
}

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 16, 2023, 3:43pm UTC](https://discuss.elastic.co/t/error-while-using-elasticsearch-node-repurpose-tool/338807/2 "2023-08-16T15:43:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
