# Error with kibana 4.2.0, Elasticsearch 2.0.0 and Logstash 2.0.0

**URL:** https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113
**Category:** Logstash
**Created:** [November 8, 2015, 4:46pm UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113 "2015-11-08T16:46:41Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Miguel\_Bessa](https://avatars.discourse-cdn.com/v4/letter/m/ecccb3/32.png) [@Miguel\_Bessa](https://discuss.elastic.co/u/Miguel_Bessa)
#### Post date: [November 8, 2015, 4:46pm UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/1 "2015-11-08T16:46:41Z")

</div>

Hi,

I installed recent versions of kibana, elasticsearch and logstash, but when I execute logstash configuration file for my logs, gives me this error:

NotImplementedError: stat.st\_dev unsupported or native support failed to load  
dev\_major at org/jruby/RubyFileStat.java:205  
inode at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.5/lib/filewatch/watch.rb:50  
\_discover\_file at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.5/lib/filewatch/watch.rb:155  
each at org/jruby/RubyArray.java:1613  
\_discover\_file at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.5/lib/filewatch/watch.rb:137  
watch at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.5/lib/filewatch/watch.rb:38  
tail at /opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.5/lib/filewatch/tail.rb:69  
run at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.0.2/lib/logstash/inputs/file.rb:190  
each at org/jruby/RubyArray.java:1613  
run at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-2.0.2/lib/logstash/inputs/file.rb:190  
inputworker at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.0.0-java/lib/logstash/pipeline.rb:180  
start\_input at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.0.0-java/lib/logstash/pipeline.rb:174

Someone can help me?

Thanks for help!

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [November 8, 2015, 8:35pm UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/2 "2015-11-08T20:35:02Z")

</div>

I believe this is the same as [github.com/elastic/logstash](http://github.com/elastic/logstash) issues [#3033](https://github.com/elastic/logstash/issues/3033) and [#3127](https://github.com/elastic/logstash/issues/3127), which list a few workarounds.

---

<div class="post-metadata">

### Author: ![Miguel\_Bessa](https://avatars.discourse-cdn.com/v4/letter/m/ecccb3/32.png) [@Miguel\_Bessa](https://discuss.elastic.co/u/Miguel_Bessa)
#### Post date: [November 9, 2015, 9:28am UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/3 "2015-11-09T09:28:14Z")

</div>

Did you have this problem with latest version of logstash?

---

<div class="post-metadata">

### Author: ![Miguel\_Bessa](https://avatars.discourse-cdn.com/v4/letter/m/ecccb3/32.png) [@Miguel\_Bessa](https://discuss.elastic.co/u/Miguel_Bessa)
#### Post date: [November 9, 2015, 10:15am UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/4 "2015-11-09T10:15:33Z")

</div>

This fix the problem I report:

ln -s /lib/x86\_64-linux-gnu/libcrypt.so.1 /usr/lib/x86\_64-linux-gnu/libcrypt.so

Solution by Jordansissel here: [https://github.com/elastic/logstash/issues/3127](https://github.com/elastic/logstash/issues/3127) .

---

<div class="post-metadata">

### Author: ![Shailen](https://avatars.discourse-cdn.com/v4/letter/s/50afbb/32.png) [@Shailen](https://discuss.elastic.co/u/Shailen)
#### Post date: [November 9, 2015, 4:23pm UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/5 "2015-11-09T16:23:55Z")

</div>

i solved this issue by copying an older version of libCrypt.so

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:23am UTC](https://discuss.elastic.co/t/error-with-kibana-4-2-0-elasticsearch-2-0-0-and-logstash-2-0-0/34113/6 "2017-07-06T05:23:24Z")

</div>


