# Error with net/smtp in Logstash (Docker)

**URL:** https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312
**Category:** Logstash
**Tags:** docker
**Created:** [October 3, 2023, 12:50pm UTC](https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312 "2023-10-03T12:50:05Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Samuele\_Lolli](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/samuele_lolli/32/107848_2.png) [@Samuele\_Lolli](https://discuss.elastic.co/u/Samuele_Lolli)
#### Post date: [October 3, 2023, 12:50pm UTC](https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312/1 "2023-10-03T12:50:05Z")

</div>

Hi everyone,  
im having some issue with docker and logstash. I have the following error:

```auto
2023-10-03 14:46:24 warning: thread "[main]-pipeline-manager" terminated with exception (report_on_exception is true):
2023-10-03 14:46:24 LoadError: no such file to load -- net/smtp
2023-10-03 14:46:24 require at org/jruby/RubyKernel.java:1057
2023-10-03 14:46:24 <module:Mail> at /usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/mail-2.6.6/lib/mail.rb:9
2023-10-03 14:46:24 <main> at /usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/mail-2.6.6/lib/mail.rb:3
2023-10-03 14:46:24 require at org/jruby/RubyKernel.java:1057
2023-10-03 14:46:24 register at /usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-input-imap-3.2.0/lib/logstash/inputs/imap.rb:89
2023-10-03 14:46:24 register_plugins at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:237
2023-10-03 14:46:24 each at org/jruby/RubyArray.java:1987
2023-10-03 14:46:24 register_plugins at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:236
2023-10-03 14:46:24 start_inputs at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:395
2023-10-03 14:46:24 start_workers at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:320
2023-10-03 14:46:24 run at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:194
2023-10-03 14:46:24 start at /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:146

```

It looks like i don't have the file net/smtp, i have checked from the files and i cant find it.  
Im using logstash on docker with WSL2.

Thank you in advance 🙂

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [October 3, 2023, 1:00pm UTC](https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312/2 "2023-10-03T13:00:02Z")

</div>

This is a bug on version 8.10.X, it is being tracked [here](https://github.com/logstash-plugins/logstash-output-email/pull/69).

You should use rollback to version 8.9.

---

<div class="post-metadata">

### Author: ![Samuele\_Lolli](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/samuele_lolli/32/107848_2.png) [@Samuele\_Lolli](https://discuss.elastic.co/u/Samuele_Lolli)
#### Post date: [October 5, 2023, 8:08am UTC](https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312/3 "2023-10-05T08:08:47Z")

</div>

Hi @leandrojmp, thank you for your help. Now im facing a different problem, i'm getting the following error:

```auto
2023-10-05 10:07:27 Oct 05, 2023 8:07:27 AM jnr.netdb.NativeProtocolsDB load
2023-10-05 10:07:27 WARNING: Failed to load native protocols db
2023-10-05 10:07:27 java.lang.RuntimeException: getprotobyname_r failed
2023-10-05 10:07:27 at jnr.netdb.NativeProtocolsDB$LinuxNativeProtocolsDB.getProtocolByName(NativeProtocolsDB.java:180)
2023-10-05 10:07:27 at jnr.netdb.NativeProtocolsDB.load(NativeProtocolsDB.java:80)
2023-10-05 10:07:27 at jnr.netdb.NativeProtocolsDB.access$000(NativeProtocolsDB.java:40)
2023-10-05 10:07:27 at jnr.netdb.NativeProtocolsDB$SingletonHolder.<clinit>(NativeProtocolsDB.java:47)
2023-10-05 10:07:27 at jnr.netdb.NativeProtocolsDB.getInstance(NativeProtocolsDB.java:43)
2023-10-05 10:07:27 at jnr.netdb.Protocol$ProtocolDBSingletonHolder.load(Protocol.java:107)
2023-10-05 10:07:27 at jnr.netdb.Protocol$ProtocolDBSingletonHolder.<clinit>(Protocol.java:103)
2023-10-05 10:07:27 at jnr.netdb.Protocol.getProtocolDB(Protocol.java:96)
2023-10-05 10:07:27 at jnr.netdb.Protocol.getProtocolByNumber(Protocol.java:59)
2023-10-05 10:07:27 at org.jruby.ext.socket.Addrinfo.<init>(Addrinfo.java:847)
2023-10-05 10:07:27 at org.jruby.ext.socket.SocketUtils$2.addrinfo(SocketUtils.java:256)
2023-10-05 10:07:27 at org.jruby.ext.socket.SocketUtils.buildAddrinfoList(SocketUtils.java:322)
2023-10-05 10:07:27 at org.jruby.ext.socket.SocketUtils.getaddrinfoList(SocketUtils.java:232)
2023-10-05 10:07:27 at org.jruby.ext.socket.Addrinfo.getaddrinfo(Addrinfo.java:322)
2023-10-05 10:07:27 at org.jruby.ext.socket.Addrinfo$INVOKER$s$0$0$getaddrinfo.call(Addrinfo$INVOKER$s$0$0$getaddrinfo.gen)
2023-10-05 10:07:27 at org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:846)
2023-10-05 10:07:27 at org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:329)
2023-10-05 10:07:27 at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:87)
2023-10-05 10:07:27 at org.jruby.ir.instructions.CallBase.interpret(CallBase.java:549)

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 2, 2023, 8:08am UTC](https://discuss.elastic.co/t/error-with-net-smtp-in-logstash-docker/344312/4 "2023-11-02T08:08:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
