# Errors have caused Elastic Cloud Enterprise installation to fail

**URL:** <https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [April 29, 2019, 2:05pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952 "2019-04-29T14:05:47Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Frrrrrunkis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/frrrrrunkis/32/42750_2.png) [@Frrrrrunkis](https://discuss.elastic.co/u/Frrrrrunkis)\
**Post date:** [April 29, 2019, 2:05pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/1 "2019-04-29T14:05:47Z")

</div>

trying the install and getting the following

[elk@console1 data]$ ./elastic-cloud-enterprise.sh install

```auto

Elastic Cloud Enterprise Installer

Start setting up a new Elastic Cloud Enterprise installation by installing the software on your first host.

This first host becomes the initial coordinator and provides access to the Cloud UI, where you can manage your installation.

To learn more about the options you can specify, see the documentation.

NOTE: If you want to add this host to an existing installation, please specify the --coordinator-host and --roles-token flags

```

-- Verifying Prerequisites --

Checking runner container does not exist... PASSED

Checking host storage root volume path is not root... PASSED

Checking host storage path is accessible... FAILED

Path /mnt/data/elastic is not readable

Checking host storage path contents matches whitelist...

```auto

Errors have caused Elastic Cloud Enterprise installation to fail

[Errno 13] Permission denied: '/mnt/data/elastic'

```

[elk@console1 data]$ docker --version  
Docker version 1.13.1, build 07f3374/1.13.1

[elk@console1 data]$ ll  
total 0

drwxrwxrwx. 2 ansible ansible 6 Apr 26 23:58 elastic

CentOS Linux release 7.4.1708 (Core)

users  
ansible:x:1000:1000::/home/ansible:/bin/bash  
dockerroot:x:994:991:Docker User:/var/lib/docker:/sbin/nologin  
elk:x:1002:1002::/home/elk:/bin/bash

groups  
ansible:x:1000:  
dockerroot:x:991:elk  
elk:x:1002:  
docker:x:1003:elk

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [April 29, 2019, 2:27pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/2 "2019-04-29T14:27:14Z")

</div>

What are the permissions on `/mnt/data/elastic` (and `/mnt`, `/mnt/data`)? Normally this happens when the installing user (`elk`?) can't write to `/mnt/data`

_(Am I reading correctly that `elk` is a member of the user `dockerroot`'s "personal" group? I think that's harmless but is there a reason for that?_)

---

<div class="post-metadata">

**Author:** ![Frrrrrunkis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/frrrrrunkis/32/42750_2.png) [@Frrrrrunkis](https://discuss.elastic.co/u/Frrrrrunkis)\
**Post date:** [April 29, 2019, 4:11pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/3 "2019-04-29T16:11:03Z")

</div>

HI Alex thank for the response and help.

sorry I copied this quickly and didn't include what this output was.

ll /mnt/data/elastic  
drwxrwxrwx. 2 ansible ansible 6 Apr 26 23:58 elastic

/mnt  
/mnt/data  
/mnt/data/elastic

are all ansible and 777 permissions.

ansible is id 1000 and thats why its used.  
elk is part of dockerroot just for troubleshooting.  
docker group was created manually

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [April 29, 2019, 4:59pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/4 "2019-04-29T16:59:07Z")

</div>

OK I _think_ I understand ... the permissions of the `/mnt/data` and children should be for the user the install script is run as. The id `1000` is just the default but any `id` can be used

So I'd delete `/mnt/data` and recreate as per the docs: (eg [https://www.elastic.co/guide/en/cloud-enterprise/2.2/ece-configure-hosts-trusty.html](https://www.elastic.co/guide/en/cloud-enterprise/2.2/ece-configure-hosts-trusty.html))

```auto
sudo install -o $USER -g $USER -d -m 700 /mnt/data
sudo mount /dev/xvdg1
sudo chown $USER:$USER /mnt/data
sudo install -o $USER -g $USER -d -m 700 /mnt/data/docker

```

where `USER` would be `elk`

---

<div class="post-metadata">

**Author:** ![Frrrrrunkis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/frrrrrunkis/32/42750_2.png) [@Frrrrrunkis](https://discuss.elastic.co/u/Frrrrrunkis)\
**Post date:** [April 29, 2019, 6:00pm UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/5 "2019-04-29T18:00:59Z")

</div>

will give it a shot !

---

<div class="post-metadata">

**Author:** ![Frrrrrunkis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/frrrrrunkis/32/42750_2.png) [@Frrrrrunkis](https://discuss.elastic.co/u/Frrrrrunkis)\
**Post date:** [May 1, 2019, 1:12am UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/6 "2019-05-01T01:12:19Z")

</div>

[elk@console1 ~]$ ./elastic-cloud-enterprise.sh install

```auto
Elastic Cloud Enterprise Installer

Start setting up a new Elastic Cloud Enterprise installation by installing the software on your first host.
This first host becomes the initial coordinator and provides access to the Cloud UI, where you can manage your installation.
To learn more about the options you can specify, see the documentation.

NOTE: If you want to add this host to an existing installation, please specify the --coordinator-host and --roles-token flags

```

-- Verifying Prerequisites --  
Checking runner container does not exist... PASSED  
Checking host storage root volume path is not root... PASSED  
Checking host storage path is accessible... PASSED  
Checking host storage path contents matches whitelist... PASSED  
Checking Docker version... PASSED  
Checking Docker file system... PASSED  
Checking Docker storage driver... PASSED

- The installation with overlay2 can proceed; however, we recommend using overlay  
Checking whether 'setuser' works inside a Docker container... PASSED  
Checking runner ip connectivity... PASSED  
Checking OS IPv4 IP forward setting... PASSED  
Checking OS max map count setting... PASSED  
Checking OS kernel version... PASSED
- OS kernel version is 3.10.0-693.el7.x86\_64 but we recommend 4.4.  
Checking minimum required memory... PASSED  
Checking OS kernel cgroup.memory... PASSED
- OS setting 'cgroup.memory' should be set to cgroup.memory=nokmem  
Checking OS minimum ephemeral port... PASSED  
Checking OS max open file descriptors per process... PASSED  
Checking OS max open file descriptors system-wide... PASSED
- OS setting for max open file descriptors system-wide should be \>= 251800, currently 65536  
Checking OS file system and Docker storage driver compatibility... PASSED  
Checking OS file system storage driver permissions... PASSED  
-- Completed Verifying Prerequisites --

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 15, 2019, 1:12am UTC](https://discuss.elastic.co/t/errors-have-caused-elastic-cloud-enterprise-installation-to-fail/178952/7 "2019-05-15T01:12:29Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
