# Errors help: Kibana error: Shard Failures FetchPhaseExecutionException

**URL:** <https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545>\
**Category:** Elasticsearch\
**Created:** [June 1, 2016, 10:24am UTC](https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545 "2016-06-01T10:24:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rag\_KD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rag_kd/32/10069_2.png) [@Rag\_KD](https://discuss.elastic.co/u/Rag_KD)\
**Post date:** [June 1, 2016, 10:24am UTC](https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545/1 "2016-06-01T10:24:42Z")

</div>

Hi all,  
New to elastic search. Have setup a cluster of three and have kibana running. Keep getting this error any ideas?

Shard Failures  
The following shard failures ocurred:

Index: logstash-2016.06.01 Shard: 0 Reason: FetchPhaseExecutionException[[logstash-2016.06.01][0]: query[filtered(ConstantScore(BooleanFilter(+cache(@timestamp:[1464733190236 TO 1464776390236]))))-\>cache(org.elasticsearch.index.search.nested.NonNestedDocsFilter@5c88f6d4)],from[0],size[500],sort[\<custom:"@timestamp": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@605471dc\>!]: Fetch Failed [Failed to highlight field [messageTemplate.raw]]]; nested: RuntimeException[org.apache.lucene.util.BytesRefHash$MaxBytesLengthExceededException: bytes can be at most 32766 in length; got 351038]; nested: MaxBytesLengthExceededException[bytes can be at most 32766 in length; got 351038];  
Index: logstash-2016.06.01 Shard: 3 Reason: RemoteTransportException[[Asp][inet[/172.26.27.165:9300]][indices:data/read/search[phase/fetch/id]]]; nested: FetchPhaseExecutionException[[logstash-2016.06.01][3]: query[filtered(ConstantScore(BooleanFilter(+cache(@timestamp:[1464733190236 TO 1464776390236]))))-\>cache(org.elasticsearch.index.search.nested.NonNestedDocsFilter@cec73a06)],from[0],size[500],sort[\<custom:"@timestamp": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@5a6167c7\>!]: Fetch Failed [Failed to highlight field [messageTemplate.raw]]]; nested: RuntimeException[org.apache.lucene.util.BytesRefHash$MaxBytesLengthExceededException: bytes can be at most 32766 in length; got 40851]; nested: MaxBytesLengthExceededException[bytes can be at most 32766 in length; got 40851];  
Index: logstash-2016.06.01 Shard: 4 Reason: RemoteTransportException[[Asp][inet[/172.26.27.165:9300]][indices:data/read/search[phase/fetch/id]]]; nested: FetchPhaseExecutionException[[logstash-2016.06.01][4]: query[filtered(ConstantScore(BooleanFilter(+cache(@timestamp:[1464733190236 TO 1464776390236]))))-\>cache(org.elasticsearch.index.search.nested.NonNestedDocsFilter@cec73a06)],from[0],size[500],sort[\<custom:"@timestamp": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@524f7ce0\>!]: Fetch Failed [Failed to highlight field [messageTemplate.raw]]]; nested: RuntimeException[org.apache.lucene.util.BytesRefHash$MaxBytesLengthExceededException: bytes can be at most 32766 in length; got 351081]; nested: MaxBytesLengthExceededException[bytes can be at most 32766 in length; got 351081];

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 2, 2016, 1:05am UTC](https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545/2 "2016-06-02T01:05:07Z")

</div>

The issue is that the `messageTemplate.raw` is too large - `bytes can be at most 32766 in length; got 351038`.

What are you trying to do in KB?

---

<div class="post-metadata">

**Author:** ![Rag\_KD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rag_kd/32/10069_2.png) [@Rag\_KD](https://discuss.elastic.co/u/Rag_KD)\
**Post date:** [June 6, 2016, 2:00pm UTC](https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545/3 "2016-06-06T14:00:01Z")

</div>

So one of my login entries is too large in size?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:45pm UTC](https://discuss.elastic.co/t/errors-help-kibana-error-shard-failures-fetchphaseexecutionexception/51545/4 "2017-07-05T22:45:56Z")

</div>


