# Errors in Kibana with Metricbeat 6.7.1+

**URL:** https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301
**Category:** Beats
**Tags:** metricbeat
**Created:** [June 18, 2019, 3:41pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301 "2019-06-18T15:41:19Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![alexz00](https://avatars.discourse-cdn.com/v4/letter/a/cc9497/32.png) [@alexz00](https://discuss.elastic.co/u/alexz00)
#### Post date: [June 18, 2019, 3:41pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/1 "2019-06-18T15:41:20Z")

</div>

Running Kibana (I tried different versions, from 6.5.x to 7.1.1) with Metricbeat 6.7.1 and 7.1.1 I see several errors in Kibana:

- Unable to see metricbeat-\* index pattern in Kibana: Request Timeout error
- Unable to open the Discover panel in Kibana: Request Timeout error
- Some system dashboard panels fail to load for timeout

See here for further details: [Kibana fails to create metricbeat index pattern](https://discuss.elastic.co/t/kibana-fails-to-create-metricbeat-index-pattern/186156)

Finally I tried Metricbeat 6.7.0, and everything started to work as expected (both with ES/Kibana 6.5.3 and 6.7.1).  
My guess is that there is something in the Elasticsearch templates starting from v. 6.7.1 that prevents Kibana to correctly generate/manage the index pattern.

---

<div class="post-metadata">

### Author: ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)
#### Post date: [June 18, 2019, 8:26pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/2 "2019-06-18T20:26:13Z")

</div>

Hi @alexz00 🙂

Can you describe the process to reproduce the issue? I'm not sure reading both posts you wrote. It seems there's a specific version mismatch that potentially is not working. You detailed the versions that worked but not specifically the ones you had originally that didn't work. You mention Elastic 6.7.1 referring to Elasticsearch 6.7.1 and Metricbeat 6.7.1?

Thanks

---

<div class="post-metadata">

### Author: ![alexz00](https://avatars.discourse-cdn.com/v4/letter/a/cc9497/32.png) [@alexz00](https://discuss.elastic.co/u/alexz00)
#### Post date: [June 19, 2019, 12:50pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/3 "2019-06-19T12:50:52Z")

</div>

Yes, sorry, my message was not so clear. But yes, it worked with ES/Kibana 6.5.3 and Metricbeat 6.7.1.

Anyway today I run some further tests and I opened Kibana from another PC (i.e. from a different Chrome instance) and also with all components on 6.7.1 it seems to work.  
I also tried from MS Edge and it seems ok.

At this point I think it was some issue between Chrome and Kibana, resulting in a Timeout Request exception. I'd close this thread (and the other one) and wait to see if the same issue happens again.

Thanks

---

<div class="post-metadata">

### Author: ![garaboncias](https://avatars.discourse-cdn.com/v4/letter/g/85e7bf/32.png) [@garaboncias](https://discuss.elastic.co/u/garaboncias)
#### Post date: [July 15, 2019, 9:35am UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/4 "2019-07-15T09:35:11Z")

</div>

As i add dashboards to kibana with "sudo metricbeat setup --dasboards" (Metricbeat 7.2 on debian) its appears but most of them broken. Example: Metricbeat-system-overview

 ![09](https://us1.discourse-cdn.com/elastic/original/3X/1/b/1bd7dc2701c01a6d3e4cfd58ac6bfb66716bd06c.png)  
 ![30](https://us1.discourse-cdn.com/elastic/original/3X/8/3/83a52fe82c9dd9260d31ca02d496987c61a5a1b0.png)  
as I see field is empty in the query  
when I check it in, query is missing and also no "savedSearchId":  
/usr/share/metricbeat/kibana/7/dashboard/Metricbeat-system-overview.json

{  
"attributes": {  
"description": "",.  
"kibanaSavedObjectMeta": {  
"searchSourceJSON": "{"filter": , "index": "metricbeat-\*", "query": {"query": "", "language":  
},.  
"title": "Number of hosts [Metricbeat System] ECS",.  
"uiStateJSON": "{"vis": {"defaultColors": {"0 - 100": "rgb(0,104,55)"}}}",.  
"version": 1,.  
"visState": "{"type": "metric", "params": {"gauge": {"useRange": false, "gaugeType": "Metric", "sty  
},.  
"id": "c6f2ffd0-4d17-11e7-a196-69b9a7a020a9-ecs",.  
"type": "visualization",.  
"version": 2  
}

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [July 16, 2019, 7:20pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/5 "2019-07-16T19:20:50Z")

</div>

Hello, what version of Kibana are you running? Also do you have metricbeat running with system enabled when you saw this error?

---

<div class="post-metadata">

### Author: ![garaboncias](https://avatars.discourse-cdn.com/v4/letter/g/85e7bf/32.png) [@garaboncias](https://discuss.elastic.co/u/garaboncias)
#### Post date: [July 16, 2019, 7:33pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/6 "2019-07-16T19:33:19Z")

</div>

Hi Kaiyan,  
I just installed the 7.2 stack

---

<div class="post-metadata">

### Author: ![garaboncias](https://avatars.discourse-cdn.com/v4/letter/g/85e7bf/32.png) [@garaboncias](https://discuss.elastic.co/u/garaboncias)
#### Post date: [July 16, 2019, 7:37pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/7 "2019-07-16T19:37:41Z")

</div>

As I got some experience it seams that fields which has ".keywords" endings seams the one of source of the issue.

---

<div class="post-metadata">

### Author: ![garaboncias](https://avatars.discourse-cdn.com/v4/letter/g/85e7bf/32.png) [@garaboncias](https://discuss.elastic.co/u/garaboncias)
#### Post date: [July 16, 2019, 8:19pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/8 "2019-07-16T20:19:49Z")

</div>

I found a similar issue:

> <https://github.com/elastic/beats/issues/6580>

  
in my case I have to modify all host.name to host.name.keyword

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [July 16, 2019, 9:06pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/9 "2019-07-16T21:06:40Z")

</div>

Hmm ok that sounds like a problem with the index pattern. Can you stop metricbeat, remove the index pattern of metricbeat from kibana management? And then remove the metricbeat index and template as well using command:

```auto
GET _cat/indices

DELETE metricbeat-7.2.0-2019.07.12-000001

GET _cat/templates

DELETE _template/metricbeat-7.2.0

```

Then restart Metricbeat with system module enabled.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 13, 2019, 9:06pm UTC](https://discuss.elastic.co/t/errors-in-kibana-with-metricbeat-6-7-1/186301/10 "2019-08-13T21:06:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
