# Errors on startup

**URL:** <https://discuss.elastic.co/t/errors-on-startup/10164>\
**Category:** Elasticsearch\
**Created:** [December 24, 2012, 2:49am UTC](https://discuss.elastic.co/t/errors-on-startup/10164 "2012-12-24T02:49:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![effektz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/effektz/32/2567_2.png) [@effektz](https://discuss.elastic.co/u/effektz)\
**Post date:** [December 24, 2012, 2:49am UTC](https://discuss.elastic.co/t/errors-on-startup/10164/1 "2012-12-24T02:49:48Z")

</div>

Elastic is throwing these errors on startup. It seems like there might be  
some (possibly corrupt) data that is causing these errors. Any help would  
be greatly appreciated.

[2012-12-23 18:01:57,852][INFO][index.gateway.local] [Kingpin]  
[wm\_index][0] ignoring recovery of a corrupt translog entry

org.elasticsearch.index.mapper.MapperParsingException: Failed to parse  
[company-intro]

at  
org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:324)

at  
org.elasticsearch.index.mapper.object.ObjectMapper.serializeValue(ObjectMapper.java:598)

at  
org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:459)

at  
org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:494)

at  
org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:438)

at  
org.elasticsearch.index.shard.service.InternalIndexShard.prepareIndex(InternalIndexShard.java:308)

at  
org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:577)

at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:213)

at  
org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)

at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)

at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)

at java.lang.Thread.run(Thread.java:636)

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:  
Illegal unquoted character ((CTRL-CHAR, code 0)): has to be escaped using  
backslash to be included in string value

at [Source: [B@25b3c442; line: 1, column: 1349]

at  
org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1284)

at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:588)

at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_throwUnquotedSpace(ParserMinimalBase.java:549)

at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString2(UTF8StreamJsonParser.java:1981)

at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString(UTF8StreamJsonParser.java:1911)

at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.getText(UTF8StreamJsonParser.java:276)

at  
org.elasticsearch.common.xcontent.json.JsonXContentParser.text(JsonXContentParser.java:83)

at  
org.elasticsearch.common.xcontent.support.AbstractXContentParser.textOrNull(AbstractXContentParser.java:106)

at  
org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateField(StringFieldMapper.java:266)

at  
org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateField(StringFieldMapper.java:44)

at  
org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:311)

... 11 more

[2012-12-23 18:01:57,857][WARN][indices.cluster] [Kingpin]  
[wm\_index][0] failed to start shard

org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[wm\_index][0] failed to recover shard

at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:227)

at  
org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)

at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)

at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)

at java.lang.Thread.run(Thread.java:636)

Caused by: java.lang.IllegalArgumentException: No type mapped for [32]

at  
org.elasticsearch.index.translog.Translog$Operation$Type.fromId(Translog.java:215)

at  
org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:34)

at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:204)

... 4 more

[2012-12-23 18:01:58,282][WARN][cluster.action.shard] [Kingpin]  
sending failed shard for [wm\_index][0], node[23XPdB7BQnGCjzGxtwb9kw], [P],  
s[INITIALIZING], reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException[[wm\_index][0] failed to recover shard];  
nested: IllegalArgumentException[No type mapped for [32]]; ]]

[2012-12-23 18:01:58,282][WARN][cluster.action.shard] [Kingpin]  
received shard failed for [wm\_index][0], node[23XPdB7BQnGCjzGxtwb9kw], [P],  
s[INITIALIZING], reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException[[wm\_index][0] failed to recover shard];  
nested: IllegalArgumentException[No type mapped for [32]]; ]]

--

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [December 24, 2012, 3:25pm UTC](https://discuss.elastic.co/t/errors-on-startup/10164/2 "2012-12-24T15:25:23Z")

</div>

It looks like transaction log for this index got truncated. Did this node  
run out of disk space of memory recently? You can try closing the index (or  
shutting down the node), moving all non zero-length translog-\* file from  
data/YOUR\_CLUSTER\_NAME/nodes/0/indices/wm\_index/0/translog to some  
temporary directory and opening the index again (or starting back the  
cluster)

On Sunday, December 23, 2012 9:49:48 PM UTC-5, Alex W wrote:

> Elastic is throwing these errors on startup. It seems like there might be  
> some (possibly corrupt) data that is causing these errors. Any help would  
> be greatly appreciated.
> 
> [2012-12-23 18:01:57,852][INFO][index.gateway.local] [Kingpin]  
> [wm\_index][0] ignoring recovery of a corrupt translog entry
> 
> org.elasticsearch.index.mapper.MapperParsingException: Failed to parse  
> [company-intro]
> 
> at  
> org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:324)
> 
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.serializeValue(ObjectMapper.java:598)
> 
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:459)
> 
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:494)
> 
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:438)
> 
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.prepareIndex(InternalIndexShard.java:308)
> 
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:577)
> 
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:213)
> 
> at  
> org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)
> 
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> 
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> 
> at java.lang.Thread.run(Thread.java:636)
> 
> Caused by: org.elasticsearch.common.jackson.core.JsonParseException:  
> Illegal unquoted character ((CTRL-CHAR, code 0)): has to be escaped using  
> backslash to be included in string value
> 
> at [Source: [B@25b3c442; line: 1, column: 1349]
> 
> at  
> org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1284)
> 
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:588)
> 
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_throwUnquotedSpace(ParserMinimalBase.java:549)
> 
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString2(UTF8StreamJsonParser.java:1981)
> 
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString(UTF8StreamJsonParser.java:1911)
> 
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.getText(UTF8StreamJsonParser.java:276)
> 
> at  
> org.elasticsearch.common.xcontent.json.JsonXContentParser.text(JsonXContentParser.java:83)
> 
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.textOrNull(AbstractXContentParser.java:106)
> 
> at  
> org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateField(StringFieldMapper.java:266)
> 
> at  
> org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateField(StringFieldMapper.java:44)
> 
> at  
> org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:311)
> 
> ... 11 more
> 
> [2012-12-23 18:01:57,857][WARN][indices.cluster] [Kingpin]  
> [wm\_index][0] failed to start shard
> 
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> [wm\_index][0] failed to recover shard
> 
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:227)
> 
> at  
> org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:177)
> 
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> 
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> 
> at java.lang.Thread.run(Thread.java:636)
> 
> Caused by: java.lang.IllegalArgumentException: No type mapped for [32]
> 
> at  
> org.elasticsearch.index.translog.Translog$Operation$Type.fromId(Translog.java:215)
> 
> at  
> org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:34)
> 
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:204)
> 
> ... 4 more
> 
> [2012-12-23 18:01:58,282][WARN][cluster.action.shard] [Kingpin]  
> sending failed shard for [wm\_index][0], node[23XPdB7BQnGCjzGxtwb9kw], [P],  
> s[INITIALIZING], reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException[[wm\_index][0] failed to recover shard];  
> nested: IllegalArgumentException[No type mapped for [32]]; ]]
> 
> [2012-12-23 18:01:58,282][WARN][cluster.action.shard] [Kingpin]  
> received shard failed for [wm\_index][0], node[23XPdB7BQnGCjzGxtwb9kw], [P],  
> s[INITIALIZING], reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException[[wm\_index][0] failed to recover shard];  
> nested: IllegalArgumentException[No type mapped for [32]]; ]]

--

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:58am UTC](https://discuss.elastic.co/t/errors-on-startup/10164/3 "2017-07-06T02:58:34Z")

</div>


