# Errors Updating logstash from 8.5.3 to 8.8.0

**URL:** <https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531>\
**Category:** Logstash\
**Tags:** elastic-stack-security\
**Created:** [June 8, 2023, 12:16pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531 "2023-06-08T12:16:56Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![cperzrt10](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cperzrt10/32/116152_2.png) [@cperzrt10](https://discuss.elastic.co/u/cperzrt10)\
**Post date:** [June 8, 2023, 12:16pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/1 "2023-06-08T12:16:56Z")

</div>

I have update all my Elasticsearch cluster, and kibana to the version 8.8.0 from 8.5.3, when update Logstash it doesnt start runing and show the next error

```auto
[2023-06-08T13:06:33,163][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "cacert" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_certificate_authorities' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}

[2023-06-08T13:06:33,173][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "ssl_certificate_verification" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_verification_mode' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}

[2023-06-08T13:06:33,174][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "ssl" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_enabled' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}
[2023-06-08T13:06:33,915][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}
[2023-06-08T13:06:33,944][ERROR][logstash.configmanagement.elasticsearchsource] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.
[2023-06-08T13:06:33,946][FATAL][logstash.runner] An unexpected error occurred! {:error=>#<LogStash::LicenseChecker::LicenseError: Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.>, :backtrace=>["/usr/share/logstash/x-pack/lib/license_checker/licensed.rb:67:in `with_license_check'", "/usr/share/logstash/x-pack/lib/config_management/elasticsearch_source.rb:43:in `initialize'", "org/jruby/RubyClass.java:911:in `new'", "/usr/share/logstash/x-pack/lib/config_management/hooks.rb:41:in `after_bootstrap_checks'", "org/logstash/execution/EventDispatcherExt.java:94:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:363:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:68:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:287:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:133:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:90:in `<main>'"]}
[2023-06-08T13:06:33,953][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:790) ~[jruby.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:753) ~[jruby.jar:?]
        at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:91) ~[?:?]

```

If i restore the old version it works fine.  
Someone knows what happend? Thank you.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [June 8, 2023, 12:27pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/2 "2023-06-08T12:27:03Z")

</div>

Hi Cristian,

> [@cperzrt10](#):
>
> ```auto
> [2023-06-08T13:06:33,163][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "cacert" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_certificate_authorities' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}
> 
> [2023-06-08T13:06:33,173][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "ssl_certificate_verification" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_verification_mode' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}
> 
> [2023-06-08T13:06:33,174][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "ssl" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'ssl_enabled' instead. If you have any questions about this, please visit the #logstash channel on freenode irc. {......}
> 
> ```

Those are deprecation warnings that you can remediate using the recommendations in the particular warning.

> [@cperzrt10](#):
>
> ```auto
> [2023-06-08T13:06:33,915][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"No Available connections"}
> [2023-06-08T13:06:33,944][ERROR][logstash.configmanagement.elasticsearchsource] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.
> [2023-06-08T13:06:33,946][FATAL][logstash.runner] An unexpected error occurred! {:error=>#<LogStash::LicenseChecker::LicenseError: Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.>, :backtrace=>["/usr/share/logstash/x-pack/lib/license_checker/licensed.rb:67:in `with_license_check'", "/usr/share/logstash/x-pack/lib/config_management/elasticsearch_source.rb:43:in `initialize'", "org/jruby/RubyClass.java:911:in `new'", "/usr/share/logstash/x-pack/lib/config_management/hooks.rb:41:in `after_bootstrap_checks'", "org/logstash/execution/EventDispatcherExt.java:94:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:363:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:68:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:287:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:133:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:90:in `<main>'"]}
> 
> ```

If looks like Logstash is not able to connect to Elasticsearch. Can you check your connection and certificate information [as per this thread](https://discuss.elastic.co/t/unable-to-retrieve-license-information-from-license-server-message-no-available-connections/302175/7)?

---

<div class="post-metadata">

**Author:** ![cperzrt10](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cperzrt10/32/116152_2.png) [@cperzrt10](https://discuss.elastic.co/u/cperzrt10)\
**Post date:** [June 8, 2023, 1:42pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/3 "2023-06-08T13:42:45Z")

</div>

If i dont update Logstash it work with ssl and certificates and all, the only thing that changes are the version, no one of the config files changes, then i udtade Logstash and it start trowing erros.  
I've redone the ssl and certifiacte configuration and it doesn work

---

<div class="post-metadata">

**Author:** ![cperzrt10](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cperzrt10/32/116152_2.png) [@cperzrt10](https://discuss.elastic.co/u/cperzrt10)\
**Post date:** [June 14, 2023, 9:17am UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/4 "2023-06-14T09:17:19Z")

</div>

I've hit a known bug for Logstash in 8.8 when upgrade to 8.8.0/8.8.1 with `xpack.management.elasticsearch.ssl.certificate_authority` configured in Logstash with centralized management setup.  
The cause is a bug introduced after SSL standardization.  
The solution is update the Elasticsearch output plugin to 11.15.8 or higher:  
bin/logstash-plugin update logstash-output-elasticsearch  
​  
Double check version:

```auto
bin/logstash-plugin list --verbose | grep logstash-output-elasticsearch

```

​OR  
Specify ca\_trusted\_fingerprint setting in the logstash.yml  
i.e. with CA ca.cert, it can be grabbed with

```auto
cat ca.cert | openssl x509 -outform der | sha256sum | awk '{print $1}'

```

Then set the following on logstash.yml using the output from the previous command (i.e. "`abbc1bd27074502451217955ffcf203770659ca70735ec3a6e2a980c6ee73a5e`"):

```auto
xpack.monitoring.elasticsearch.ssl.ca_trusted_fingerprint: "abbc1bd27074502451217955ffcf203770659ca70735ec3a6e2a980c6ee73a5e"
xpack.management.elasticsearch.ssl.ca_trusted_fingerprint: "abbc1bd27074502451217955ffcf203770659ca70735ec3a6e2a980c6ee73a5e"

```

---

<div class="post-metadata">

**Author:** ![ramiwashere](https://avatars.discourse-cdn.com/v4/letter/r/6f9a4e/32.png) [@ramiwashere](https://discuss.elastic.co/u/ramiwashere)\
**Post date:** [June 14, 2023, 3:32pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/5 "2023-06-14T15:32:50Z")

</div>

Hello,

Not working for me after upgrading to 8.8.1.  
(no plugin found on /bin/logstash also).

There is some link about this error:

> <https://github.com/elastic/logstash/issues/15068>
>
> \*\*Logstash information\*\*:
> 
> Please include the following information:
> 
> 1. Log…stash version (e.g. \`bin/logstash --version\`) 
> 8.8.0
> 
> 3. Logstash installation source (e.g. built from source, with a package manager: DEB/RPM, expanded from tar or zip archive, docker) 
> 
> Docker
> 4. How is Logstash being run (e.g. as a service/service manager: systemd, upstart, etc. Via command line, docker/kubernetes) 
> K8S
> 
> \*\*Plugins installed\*\*: (\`bin/logstash-plugin list --verbose\`)
> Default
> 
> \*\*JVM\*\* (e.g. \`java -version\`):
> Starting Logstash {"logstash.version"=\>"8.8.0", "jruby.version"=\>"jruby 9.3.10.0 (2.6.8) 2023-02-01 107b2e6697 OpenJDK 64-Bit Server VM 17.0.7+7 on 17.0.7+7 +indy +jit \[x86\_64-linux\]"}
> 
> \*\*OS version\*\* (\`uname -a\` if on a Unix-like system):
> 
> \*\*Description of the problem including expected versus actual behavior\*\*:
> After upgrading to 8.8.0 from 8.7.1 Logstash fails to start due to xpack management TLS certificate error message
> 
> 
> 
> \*\*Steps to reproduce\*\*:
> 
> Please include a \*minimal\* but \*complete\* recreation of the problem,
> including (e.g.) pipeline definition(s), settings, locale, etc. The easier
> you make for us to reproduce it, the more likely that somebody will take the
> time to look at it.
> 
> 1. Upgrade from 8.7.1 to 8.8.0 with xpack.management.elasticsearch.ssl.certificate\_authority configured
> 2.
> 3.
> 
> \*\*Provide logs (if relevant)\*\*:
> \`\`\`
> logstash-1 logstash \[2023-05-25T14:13:27,199\]\[INFO \]\[logstash.licensechecker.licensereader\] Failed to perform request {:message=\>"PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target", :exception=\>Manticore::ClientProtocolException, :cause=\>#\<Java::JavaxNetSsl::SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target\>}
> logstash-1 logstash \[2023-05-25T14:13:27,201\]\[WARN \]\[logstash.licensechecker.licensereader\] Marking url as dead. Last error: \[LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError\] Elasticsearch Unreachable: \[https://REPLACED:9200/\_xpack\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target {:url=\>https://REPLACED:xxxxxx@REPLACED:9200/, :error\_message=\>"Elasticsearch Unreachable: \[https://REPLACED:9200/\_xpack\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target", :error\_class=\>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError"}
> logstash-1 logstash \[2023-05-25T14:13:27,202\]\[WARN \]\[logstash.licensechecker.licensereader\] Attempt to validate Elasticsearch license failed. Sleeping for 0.04 {:fail\_count=\>2, :exception=\>"Elasticsearch Unreachable: \[https://REPLACED:9200/\_xpack\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"}
> logstash-1 logstash \[2023-05-25T14:13:27,243\]\[ERROR\]\[logstash.licensechecker.licensereader\] Unable to retrieve license information from license server {:message=\>"No Available connections"}
> logstash-1 logstash \[2023-05-25T14:13:27,254\]\[ERROR\]\[logstash.configmanagement.elasticsearchsource\] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.
> logstash-1 logstash \[2023-05-25T14:13:27,255\]\[FATAL\]\[logstash.runner \] An unexpected error occurred! {:error=\>#\<LogStash::LicenseChecker::LicenseError: Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.\>, :backtrace=\>\["/usr/share/logstash/x-pack/lib/license\_checker/licensed.rb:67:in \`with\_license\_check'", "/usr/share/logstash/x-pack/lib/config\_management/elasticsearch\_source.rb:43:in \`initialize'", "org/jruby/RubyClass.java:890:in \`new'", "/usr/share/logstash/x-pack/lib/config\_management/hooks.rb:41:in \`after\_bootstrap\_checks'", "org/logstash/execution/EventDispatcherExt.java:94:in \`execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:363:in \`execute'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:68:in \`run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:287:in \`run'", "/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:133:in \`run'", "/usr/share/logstash/lib/bootstrap/environment.rb:90:in \`\<main\>'"\]}
> logstash-1 logstash \[2023-05-25T14:13:27,259\]\[FATAL\]\[org.logstash.Logstash \] Logstash stopped processing because of an error: (SystemExit) exit
> \`\`\`
> config:
> \`\`\`
> xpack.management.elasticsearch.ssl.certificate\_authority: "/usr/share/logstash/conf.d/ssl/elasticsearch-ca.pem"
> xpack.management.elasticsearch.ssl.verification\_mode: "certificate"
> 
> \`\`\`
> 
> mounted secret in container:
> \`\`\`
> logstash@logstash-0:~$ ls -lh /usr/share/logstash/conf.d/ssl/elasticsearch-ca.pem
> lrwxrwxrwx 1 root logstash 27 May 13 22:23 /usr/share/logstash/conf.d/ssl/elasticsearch-ca.pem -\> ..data/elasticsearch-ca.pem
> 
> \`\`\`

> <https://github.com/sherifabdlnaby/elastdocker/issues/102>
>
> I am experiencing an issue where I am unable to see logstash under Cluster overv…iew in my setup. Additionally, I am encountering the following error messages repeatedly:
> 
> !\[image\](https://github.com/sherifabdlnaby/elastdocker/assets/24693946/a4478398-c15b-48de-9511-d783d39262ae)
> 
> 
> \`\`\`
> elastic-logstash-1 | \[2023-06-07T06:53:13,041\]\[ERROR\]\[logstash.licensechecker.licensereader\] Unable to retrieve license information from license server {:message=\>"No Available connections"}
> elastic-logstash-1 | \[2023-06-07T06:53:13,706\]\[INFO \]\[logstash.licensechecker.licensereader\] Failed to perform request {:message=\>"PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target", :exception=\>Manticore::ClientProtocolException, :cause=\>#\<Java::JavaxNetSsl::SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target\>}
> elastic-logstash-1 | \[2023-06-07T06:53:13,709\]\[WARN \]\[logstash.licensechecker.licensereader\] Attempted to resurrect connection to dead ES instance, but got an error {:url=\>"https://elastic:xxxxxx@elasticsearch:9200/", :exception=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=\>"Elasticsearch Unreachable: \[https://elasticsearch:9200/\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"}
> elastic-logstash-1 | \[2023-06-07T06:53:43,041\]\[ERROR\]\[logstash.licensechecker.licensereader\] Unable to retrieve license information from license server {:message=\>"No Available connections"}
> elastic-logstash-1 | \[2023-06-07T06:53:43,738\]\[INFO \]\[logstash.licensechecker.licensereader\] Failed to perform request {:message=\>"PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target", :exception=\>Manticore::ClientProtocolException, :cause=\>#\<Java::JavaxNetSsl::SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target\>}
> elastic-logstash-1 | \[2023-06-07T06:53:43,744\]\[WARN \]\[logstash.licensechecker.licensereader\] Attempted to resurrect connection to dead ES instance, but got an error {:url=\>"https://elastic:xxxxxx@elasticsearch:9200/", :exception=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=\>"Elasticsearch Unreachable: \[https://elasticsearch:9200/\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"}
> elastic-logstash-1 | \[2023-06-07T06:54:13,040\]\[ERROR\]\[logstash.licensechecker.licensereader\] Unable to retrieve license information from license server {:message=\>"No Available connections"}
> elastic-logstash-1 | \[2023-06-07T06:54:13,771\]\[INFO \]\[logstash.licensechecker.licensereader\] Failed to perform request {:message=\>"PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target", :exception=\>Manticore::ClientProtocolException, :cause=\>#\<Java::JavaxNetSsl::SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target\>}
> elastic-logstash-1 | \[2023-06-07T06:54:13,772\]\[WARN \]\[logstash.licensechecker.licensereader\] Attempted to resurrect connection to dead ES instance, but got an error {:url=\>"https://elastic:xxxxxx@elasticsearch:9200/", :exception=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :message=\>"Elasticsearch Unreachable: \[https://elasticsearch:9200/\]\[Manticore::ClientProtocolException\] PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"}
> 
> \`\`\`
> 
> 
> My configuration settings are set to the default values as follows:
> \*ELK 8.8.0
> 
> \`\`\`
> git clone https://github.com/sherifabdlnaby/elastdocker.git
> make setup
> make elk
> 
> \`\`\`
> 
> I have checked the status of the logstash containers and they appear to be healthy:
> \`\`\`
> \[root@elk1 elastdocker\]# docker ps -a
> CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
> fb3e1e604b3b elastdocker/logstash:8.8.0 "/usr/local/bin/dock…" 6 minutes ago Up 6 minutes (healthy) 0.0.0.0:5044-\>5044/tcp, :::5044-\>5044/tcp, 0.0.0.0:9600-\>9600/tcp, :::9600-\>9600/tcp elastic-logstash-1
> 1aa62265a433 elastdocker/kibana:8.8.0 "/bin/tini -- /usr/l…" 6 minutes ago Up 6 minutes 0.0.0.0:5601-\>5601/tcp, :::5601-\>5601/tcp elastic-kibana-1
> ea7e23818a0a elastdocker/apm-server:8.8.0 "/usr/bin/tini -- /u…" 6 minutes ago Up 6 minutes 0.0.0.0:8200-\>8200/tcp, :::8200-\>8200/tcp elastic-apm-server-1
> 814c7980cd7b elastdocker/elasticsearch:8.8.0 "/bin/tini -- /usr/l…" 6 minutes ago Up 6 minutes (healthy) 0.0.0.0:9200-\>9200/tcp, :::9200-\>9200/tcp, 0.0.0.0:9300-\>9300/tcp, :::9300-\>9300/tcp elastic-elasticsearch-1
> 
> \`\`\`
> 
> Anyone else have a similar issue too?

Case created on my side for an official recommandation

---

<div class="post-metadata">

**Author:** ![ramiwashere](https://avatars.discourse-cdn.com/v4/letter/r/6f9a4e/32.png) [@ramiwashere](https://discuss.elastic.co/u/ramiwashere)\
**Post date:** [June 15, 2023, 12:29pm UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/6 "2023-06-15T12:29:42Z")

</div>

For the noob like me:  
The real path is /usr/share/logstash, then apply the command provided below:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/4/c4aa90e9361f09ecf4d60fd7d7ae399202b1e9bc.png)

And the workaround is OK

---

<div class="post-metadata">

**Author:** ![cperzrt10](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cperzrt10/32/116152_2.png) [@cperzrt10](https://discuss.elastic.co/u/cperzrt10)\
**Post date:** [June 19, 2023, 10:03am UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/7 "2023-06-19T10:03:52Z")

</div>

Yes the route /bin ... is relative the complete is what you've post

all is especified [here](https://www.elastic.co/guide/en/logstash/current/dir-layout.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 17, 2023, 10:04am UTC](https://discuss.elastic.co/t/errors-updating-logstash-from-8-5-3-to-8-8-0/335531/8 "2023-07-17T10:04:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
